summary refs log tree commit diff
path: root/gnu/packages/lisp-check.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-11-21 12:55:08 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2022-11-22 10:08:57 +0100
commit0435469669ad1f8d02c9580a5eaea6d89bfea66e (patch)
tree11a73e0562b48b1ebbe7a2ee44c865da4e21ea8a /gnu/packages/lisp-check.scm
parentbb829bb23bc85e8218855e477c564e3b72579069 (diff)
downloadguix-0435469669ad1f8d02c9580a5eaea6d89bfea66e.tar.gz
gnu: cl-parachute: Update to 1.5.0-0.8bc3e1b.
* gnu/packages/lisp-check.scm (sbcl-parachute): Update to
  1.5.0-0.8bc3e1b.
  [inputs]: Add sbcl-trivial-custom-debugger.
* gnu/packages/lisp-xyz.scm (sbcl-trivial-custom-debugger)
  [arguments]: New field.
  [native-inputs]: Remove field.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-check.scm')
-rw-r--r--gnu/packages/lisp-check.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index 7002cd9d92..58b79ba6e5 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -634,11 +634,11 @@ by Chris Riesbeck.")
   (sbcl-package->cl-source-package sbcl-nst))
 
 (define-public sbcl-parachute
-  (let ((commit "86563473dc23fb1277d35a3ad2c911a6c8e5b0da")
-        (revision "1"))
+  (let ((commit "8bc3e1b5a1808341967aeb89516f9fab23cd1d9e")
+        (revision "0"))
     (package
       (name "sbcl-parachute")
-      (version (git-version "1.1.1" revision commit))
+      (version (git-version "1.5.0" revision commit))
       (source
        (origin
          (method git-fetch)
@@ -646,13 +646,14 @@ by Chris Riesbeck.")
           (git-reference
            (url "https://github.com/Shinmera/parachute")
            (commit commit)))
-         (file-name (git-file-name name version))
+         (file-name (git-file-name "cl-parachute" version))
          (sha256
-          (base32
-           "026crl465xqh3fnskfd4c1sxa9c33dfy702cf3l5apbjyj1dg20n"))))
+          (base32 "0cppp1sp9xqkgxgkwidhqzlsj03ywnar7z9mzwcliww8y0kv5555"))))
       (build-system asdf-build-system/sbcl)
       (inputs
-       (list sbcl-documentation-utils sbcl-form-fiddle))
+       (list sbcl-documentation-utils
+             sbcl-form-fiddle
+             sbcl-trivial-custom-debugger))
       (synopsis "Extensible and cross-compatible testing framework for Common Lisp")
       (description
        "Parachute is a simple-to-use and extensible testing framework.