summary refs log tree commit diff
path: root/gnu/packages/lisp-check.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-07-07 09:59:59 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2022-07-08 19:32:44 +0200
commitfef5fa48151071d4d287a2b772b81c88bec67cd5 (patch)
tree912356ab99b96bfd0ed25614374011461b249a6b /gnu/packages/lisp-check.scm
parentd14070bd29de2edd25a57c4618cb3fae6445b47d (diff)
downloadguix-fef5fa48151071d4d287a2b772b81c88bec67cd5.tar.gz
gnu: sbcl-rt: Remove Make reference from closure.
* gnu/packages/lisp-check.scm (sbcl-rt)[source]: Delete the 'debian' folder.

This takes the closure size from 209 MiB down to 151 MiB.
Diffstat (limited to 'gnu/packages/lisp-check.scm')
-rw-r--r--gnu/packages/lisp-check.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index 6b13daf9c5..1795e050a4 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -755,7 +755,13 @@ This is intended to be a successor of Prove.")
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
-          (base32 "13si2rrxaagbr0bkvg6sqicxxpyshabx6ad6byc9n2ik5ysna69b"))))
+          (base32 "13si2rrxaagbr0bkvg6sqicxxpyshabx6ad6byc9n2ik5ysna69b"))
+         (modules '((guix build utils)))
+         (snippet
+          ;; The useless bundled debian folder drags `make' into the closure.
+          `(begin
+             (delete-file-recursively "debian")
+             #t))))
       (build-system asdf-build-system/sbcl)
       (synopsis "MIT Regression Tester")
       (description