summary refs log tree commit diff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2023-04-12 10:54:19 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2023-04-12 12:23:52 +0200
commit18584d665e9a1daa90c1404483f5255c581d1e72 (patch)
tree82f95e51d7131c4dad4f2ed35358e94cb22c8d75 /gnu/packages/lisp-xyz.scm
parent81a3b4cef231b5976d3d65e95a4babc8ed27c167 (diff)
downloadguix-18584d665e9a1daa90c1404483f5255c581d1e72.tar.gz
gnu: Add maiden.
* gnu/packages/lisp-xyz.scm (cl-maiden, ecl-maiden, sbcl-maiden): New variables.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 07bce358ee..6080b2d8e2 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -29032,6 +29032,61 @@ for the specific kind of project you're building to get the full picture.")
 (define-public forge
   (sbcl-package->cl-source-package sbcl-forge))
 
+(define-public sbcl-maiden
+  (let ((commit "164e8df1b513fcbf097315b51242d337c183a5ef")
+        (revision "1"))
+    (package
+      (name "sbcl-maiden")
+      (version (git-version "3.1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Shirakumo/maiden/")
+               (commit commit)))
+         (sha256
+          (base32 "1m16qi019cmfpfs6538hc4qsplpb8nl9ly1qlckgfxgjag0z3wdr"))
+         (file-name (git-file-name "maiden" version))))
+      (build-system asdf-build-system/sbcl)
+      (arguments
+       '(#:asd-systems '("maiden"
+                         "maiden-commands"
+                         "maiden-networking"
+                         "maiden-client-entities"
+                         "maiden-irc"
+                         "maiden-silly")))
+      (inputs
+       (list sbcl-alexandria
+             sbcl-babel
+             sbcl-bordeaux-threads
+             sbcl-cl-base64
+             sbcl-cl+ssl
+             sbcl-closer-mop
+             sbcl-deeds
+             sbcl-documentation-utils
+             sbcl-drakma
+             sbcl-form-fiddle
+             sbcl-jsown
+             sbcl-lambda-fiddle
+             sbcl-lquery
+             sbcl-pathname-utils
+             sbcl-trivial-garbage
+             sbcl-trivial-indent
+             sbcl-ubiquitous
+             sbcl-usocket
+             sbcl-uuid
+             sbcl-verbose))
+      (synopsis "Modern and extensible chat bot framework")
+      (description "Maiden is a collection of systems to help you build
+applications and libraries that interact with chat servers.  It can help you
+build a chat bot, or a general chat client.  It also offers a variety of parts
+that should make it much easier to write a client for a new chat protocol.")
+      (home-page "http://shirakumo.github.io/maiden/")
+      (license license:zlib))))
+
+(define-public maiden
+  (sbcl-package->cl-source-package sbcl-maiden))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar