summary refs log tree commit diff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2020-06-05 14:59:19 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-06-05 15:01:07 +0200
commit019ff3c3c74048a133263ccacac3db87e52bc00a (patch)
treee9d258af512cfbeb07a70866f56af45d1534afdc /gnu/packages/lisp-xyz.scm
parent78d1aa9eef788654ce3c8440a86927a219b3c4fa (diff)
downloadguix-019ff3c3c74048a133263ccacac3db87e52bc00a.tar.gz
gnu: Add cl-prometheus.exposers.hunchentoot.
* gnu/packages/lisp-xyz.scm (sbcl-prometheus.exposers.hunchentoot,
  cl-prometheus.exposers.hunchentoot): New variables.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 9af4b851fa..3156bc9de2 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -11667,3 +11667,19 @@ Streams in ICDE’05.")
 
 (define-public ecl-prometheus.formats.text
   (sbcl-package->ecl-package sbcl-prometheus.formats.text))
+
+(define-public sbcl-prometheus.exposers.hunchentoot
+  (package
+    (inherit sbcl-prometheus)
+    (name "sbcl-prometheus.exposers.hunchentoot")
+    (inputs
+     `(("hunchentoot" ,sbcl-hunchentoot)
+       ("prometheus" ,sbcl-prometheus)
+       ("prometheus.formats.text" ,sbcl-prometheus.formats.text)
+       ("salza2" ,sbcl-salza2)
+       ("trivial-utf-8" ,sbcl-trivial-utf-8)))
+    (synopsis "Prometheus collector for Hunchentoot metrics")
+    (description "Prometheus collector for Hunchentoot metrics")))
+
+(define-public cl-prometheus.exposers.hunchentoot
+  (sbcl-package->cl-source-package sbcl-prometheus.exposers.hunchentoot))