summary refs log tree commit diff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-09-18 16:37:33 -0500
committerGuillaume Le Vaillant <glv@posteo.net>2022-09-19 11:11:56 +0200
commit4ca4b96e2a674ac53c90315d98ff8ec614f0e606 (patch)
tree76cbd2b40361d634e81f8ac5e3a981397129c2b0 /gnu/packages/lisp-xyz.scm
parentf9ada7fdc4d4dad63a3bbb4a43bbb3f8441f0c60 (diff)
downloadguix-4ca4b96e2a674ac53c90315d98ff8ec614f0e606.tar.gz
gnu: Add cl-bubble-operator-upwards.
* gnu/packages/lisp-xyz.scm (cl-bubble-operator-upwards,
  ecl-bubble-operator-upwards, sbcl-bubble-operator-upwards): New variables.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index bb1cfc329d..33d7b64d61 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -214,6 +214,38 @@ with dice-roll statistics.")
 (define-public ecl-alea
   (sbcl-package->ecl-package sbcl-alea))
 
+(define-public sbcl-bubble-operator-upwards
+  (let ((commit "846275a318b960de81b62caecb1e31930f70aef6")
+        (revision "0"))
+    (package
+      (name "sbcl-bubble-operator-upwards")
+      (version (git-version "1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Hexstream/bubble-operator-upwards")
+               (commit commit)))
+         (file-name (git-file-name "cl-bubble-operator-upwards" version))
+         (sha256
+          (base32 "0ybsy29ms3yrxgr7f2146lr6z4vm070dvdyzvwwxjh4dgm9na7bi"))))
+      (build-system asdf-build-system/sbcl)
+      (native-inputs
+       (list sbcl-parachute))
+      (home-page "https://www.hexstreamsoft.com/libraries/bubble-operator-upwards/")
+      (synopsis "Function that bubbles an operator upwards in a form")
+      (description
+       "@code{bubble-operator-upwards} is a function that bubbles an operator
+upwards in a form, demultiplexing all alternative branches by way of
+cartesian product.")
+      (license license:unlicense))))
+
+(define-public cl-bubble-operator-upwards
+  (sbcl-package->cl-source-package sbcl-bubble-operator-upwards))
+
+(define-public ecl-bubble-operator-upwards
+  (sbcl-package->ecl-package sbcl-bubble-operator-upwards))
+
 (define-public sbcl-map-bind
   (let ((commit "532d55d93540c632e22b2cd264b5daa5f9d3d900")
         (revision "0"))