summary refs log tree commit diff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-02-28 19:15:36 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-02-28 23:38:38 +0100
commitcd53df62c9d0872331c6872727feeb5aca6cd3f6 (patch)
treec43885058eae1eb4a956295b9a6c7880c88385eb /gnu/packages/lisp-xyz.scm
parent5ad8d7aa12afc5c76614a1bf2b03d33cc161cb2a (diff)
downloadguix-cd53df62c9d0872331c6872727feeb5aca6cd3f6.tar.gz
gnu: Add sbcl-clsql-postgresql.
* gnu/packages/lisp-xyz.scm (sbcl-clsql-postgresql): New variable.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 2567beabb0..300638ba03 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -11107,3 +11107,24 @@ interfaces as well as a functional and an object oriented interface.")
                                  "/lib/libsqlite3")))
                #t))))))
     (synopsis "SQLite3 driver for Common Lisp SQL interface library")))
+
+(define-public sbcl-clsql-postgresql
+  (package
+    (inherit sbcl-clsql)
+    (name "sbcl-clsql-postgresql")
+    (inputs
+     `(("clsql" ,sbcl-clsql)
+       ("clsql-uffi" ,sbcl-clsql-uffi)
+       ("postgresql" ,postgresql)))
+    (arguments
+     (substitute-keyword-arguments (package-arguments sbcl-clsql)
+       ((#:phases phases '%standard-phases)
+        `(modify-phases ,phases
+           (add-after 'unpack 'fix-paths
+             (lambda* (#:key inputs #:allow-other-keys)
+               (substitute* "db-postgresql/postgresql-loader.lisp"
+                 (("libpq")
+                  (string-append (assoc-ref inputs "postgresql")
+                                 "/lib/libpq")))
+               #t))))))
+    (synopsis "PostgreSQL driver for Common Lisp SQL interface library")))