summary refs log tree commit diff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-01-04 23:31:10 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-01-05 20:45:22 +0100
commit5dfde3f5862eb542407b70db4b53b6b33a59b38e (patch)
treeda4147e97b4e79fbbb9ffe5c58fcf480b782d5e9 /gnu/packages/lisp-xyz.scm
parent7c62d384659d1292e418b951d516bb24d998bf2e (diff)
downloadguix-5dfde3f5862eb542407b70db4b53b6b33a59b38e.tar.gz
gnu: Add cl-flexichain.
* gnu/packages/lisp-xyz.scm (sbcl-flexichain, ecl-flexichain, cl-flexichain):
New variables.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 5df6a308ff..45d79152c8 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -518,6 +518,38 @@ spatially-extended data.")
 (define-public cl-spatial-trees
   (sbcl-package->cl-source-package sbcl-spatial-trees))
 
+(define-public sbcl-flexichain
+  ;; There are no releases.
+  (let ((commit "13d2a6c505ed0abfcd4c4ec7d7145059b06855d6")
+        (revision "1"))
+    (package
+      (name "sbcl-flexichain")
+      (version "1.5.1")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/robert-strandh/Flexichain.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0pfyvhsfbjd2sjb30grfs52r51a428xglv7bwydvpg2lc117qimg"))))
+      (build-system asdf-build-system/sbcl)
+      (home-page "https://github.com/robert-strandh/Flexichain.git")
+      (synopsis "Dynamically add elements to or remove them from sequences")
+      (description
+       "This package provides an implementation of the flexichain protocol,
+allowing client code to dynamically add elements to, and delete elements from
+a sequence (or chain) of such elements.")
+      (license license:lgpl2.1+))))
+
+(define-public ecl-flexichain
+  (sbcl-package->ecl-package sbcl-flexichain))
+
+(define-public cl-flexichain
+  (sbcl-package->cl-source-package sbcl-flexichain))
+
 (define-public sbcl-clx
   (package
     (name "sbcl-clx")