summary refs log tree commit diff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-02-03 16:49:32 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-02-03 17:12:07 +0100
commit17c015c9099b4e57fbcb13a7388c24dfe77df684 (patch)
treecf9da82fdefcf28c0b8125f7a220979f108838a6 /gnu/packages/lisp-xyz.scm
parent7e23dcc73ec501d857cb649c29172ecaae630f81 (diff)
downloadguix-17c015c9099b4e57fbcb13a7388c24dfe77df684.tar.gz
gnu: sbcl-graph: Fix build.
Rename the asd files so that they have the same name as the ASDF
system definitions.

* gnu/packages/lisp-xyz.scm (sbcl-graph)[arguments]: Use 'graph-test.asd'
  instead of 'graph.test.asd' for test-asd-file.
  (sbcl-graph-dot)[arguments]: Use 'graph-dot.asd' instead of 'graph.dot.asd'
  for test-asd-file.
  (sbcl-graph-json)[arguments]: Use 'graph-json.asd' instead of
  'graph.json.asd' for test-asd-file.
* gnu/packages/patches/sbcl-graph-asdf-definitions.patch: Update accordingly.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index ebf0d79882..66085919b1 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -7438,7 +7438,7 @@ interactive development.")
          ("metabang-bind" ,sbcl-metabang-bind)
          ("named-readtables" ,sbcl-named-readtables)))
       (arguments
-       '(#:test-asd-file "graph.test.asd"))
+       '(#:test-asd-file "graph-test.asd"))
       (synopsis "Graph data structure and algorithms for Common Lisp")
       (description
        "The GRAPH Common Lisp library provides a data structures to represent
@@ -7463,7 +7463,7 @@ path, maximum flow, minimum spanning tree, etc.).")
        ("named-readtables" ,sbcl-named-readtables)))
     (arguments
      (substitute-keyword-arguments (package-arguments sbcl-graph)
-       ((#:asd-file _ "") "graph.dot.asd")
+       ((#:asd-file _ "") "graph-dot.asd")
        ((#:asd-system-name _ #f) "graph-dot")))
     (synopsis "Serialize graphs to and from DOT format")))
 
@@ -7480,7 +7480,7 @@ path, maximum flow, minimum spanning tree, etc.).")
        ("yason" ,sbcl-yason)))
     (arguments
      (substitute-keyword-arguments (package-arguments sbcl-graph)
-       ((#:asd-file _ "") "graph.json.asd")
+       ((#:asd-file _ "") "graph-json.asd")
        ((#:asd-system-name _ #f) "graph-json")))
     (synopsis "Serialize graphs to and from JSON format")))