summary refs log tree commit diff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2021-07-17 23:19:31 -0400
committerGuillaume Le Vaillant <glv@posteo.net>2021-07-20 10:09:33 +0200
commit6a0658afa7388f2b9f55a2ef437ae0c2776e19b8 (patch)
tree4bf9ca22cd82ec949876d609dfe1877c5dc297c5 /gnu/packages/lisp.scm
parent75922458af60081bf6964006d5b9c180ff9ec8ca (diff)
downloadguix-6a0658afa7388f2b9f55a2ef437ae0c2776e19b8.tar.gz
gnu: txr: Fix license installation.
The install-license-files phase was installing LICENSE-CYG when it
shouldn't have, because that license applies only to TXR builds for
Microsoft Windows; and it was also ignoring the METALICENSE file.
However, TXR's Makefile was already installing the LICENSE and
METALICENSE files into share/txr (the datadir), so redirect them into
the appropriate doc directory and delete the install-license-files
phase.

* gnu/packages/lisp.scm (txr)[arguments]<#:phases>
  {fix-license-installation}: New phase.
  {install-license-files}: Delete phase.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index e6d09ce353..dbeeb5cd60 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -931,6 +931,15 @@ the HTML documentation of TXR.")
        #:test-target "tests"
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'fix-license-installation
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* "Makefile"
+               (("INSTALL(,.*LICENSE,.*)\\$\\(datadir\\)" _ match)
+                (string-append "INSTALL" match
+                               (assoc-ref outputs "out")
+                               "/share/doc/" ,name "-" ,version)))
+             #t))
+         (delete 'install-license-files)
          (add-after 'unpack 'inhibit-doc-syms-generation
            (lambda _
              (substitute* "genman.txr"