summary refs log tree commit diff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-07 04:27:19 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-07 05:57:53 +0100
commit363d872167ec0cf87cf811ee4c40e21780556d1a (patch)
tree2ebce68a0449783fc2264693651ba1de931666e5 /gnu/packages/lisp.scm
parent58fd2385208a0713885422f2e9e23e4a6d5c0898 (diff)
downloadguix-363d872167ec0cf87cf811ee4c40e21780556d1a.tar.gz
gnu: txr: Update to 273.
* gnu/packages/lisp.scm (txr): Update to 273.
[arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm19
1 files changed, 7 insertions, 12 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 8edff11cb3..80d7585387 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -915,7 +915,7 @@ the HTML documentation of TXR.")
 (define-public txr
   (package
     (name "txr")
-    (version "270")
+    (version "273")
     (source
      (origin
        (method git-fetch)
@@ -924,7 +924,7 @@ the HTML documentation of TXR.")
              (commit (string-append "txr-" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1kp64h3ls8mddvrlaqqylrb3brckfrqvkk8049xn15mimfggg0xv"))))
+        (base32 "1m4akw64458qcrfbqv71z9y8q9dszj26d7jfqblcn6nn8akx2jyb"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags
@@ -939,8 +939,7 @@ the HTML documentation of TXR.")
                (("INSTALL(,.*LICENSE,.*)\\$\\(datadir\\)" _ match)
                 (string-append "INSTALL" match
                                (assoc-ref outputs "out")
-                               "/share/doc/" ,name "-" ,version)))
-             #t))
+                               "/share/doc/" ,name "-" ,version)))))
          (delete 'install-license-files)
          (add-after 'unpack 'inhibit-doc-syms-generation
            (lambda _
@@ -950,8 +949,7 @@ the HTML documentation of TXR.")
                ;; each release (and is already compiled to stdlib/doc-syms.tlo
                ;; when genman.txr is run).
                (("^@\\(output \"stdlib/doc-syms\\.tl\"\\).*" line)
-                (string-append "@(do (exit))\n" line)))
-             #t))
+                (string-append "@(do (exit))\n" line)))))
          (add-after 'unpack 'fix-paths
            (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "stream.c"
@@ -967,20 +965,17 @@ the HTML documentation of TXR.")
            ;; autotools arguments like CONFIG_SHELL.
            (lambda* (#:key configure-flags #:allow-other-keys)
              (setenv "txr_shell" (which "bash"))
-             (apply invoke "./configure" configure-flags)
-             #t))
+             (apply invoke "./configure" configure-flags)))
          (add-after 'build 'build-doc
            (lambda _
              (setenv "GS_GENERATE_UUIDS" "0")
-             (invoke "make" "txr-manpage.html" "txr-manpage.pdf")
-             #t))
+             (invoke "make" "txr-manpage.html" "txr-manpage.pdf")))
          (add-after 'install 'install-doc
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((doc (string-append (assoc-ref outputs "out")
                                        "/share/doc/" ,name "-" ,version)))
                (for-each (lambda (f) (install-file f doc))
-                         '("txr-manpage.html" "txr-manpage.pdf")))
-             #t)))))
+                         '("txr-manpage.html" "txr-manpage.pdf"))))))))
     (native-inputs
      ;; Required to build the documentation.
      (list ghostscript