summary refs log tree commit diff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorng0 <ngillmann@runbox.com>2016-09-22 09:08:03 +0000
committerLeo Famulari <leo@famulari.name>2016-09-27 12:29:35 -0400
commit419fb3f1acc834e7cfc7e395b43be3cc1ddfadbf (patch)
treed2e27dc971ae179bd169653bb40f431650aafdfc /gnu/packages/lisp.scm
parente9070933bfe23412fce21237c51c6d2d86cb8681 (diff)
downloadguix-419fb3f1acc834e7cfc7e395b43be3cc1ddfadbf.tar.gz
gnu: femtolisp: Don't build on mips64el or armhf.
* gnu/packages/lisp.scm (femtolisp)[supported-systems]: New field,
remove support for mips64el and armhf.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index d1180a7d6d..439433a22b 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -3,7 +3,7 @@
 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016 Federico Beffa <beffa@fbengineering.ch>
-;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016 ng0 <ngillmann@runbox.com>
 ;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -44,7 +44,8 @@
   #:use-module (gnu packages ed)
   #:use-module (gnu packages m4)
   #:use-module (gnu packages version-control)
-  #:use-module (ice-9 match))
+  #:use-module (ice-9 match)
+  #:use-module (srfi srfi-1))
 
 (define-public gcl
   (package
@@ -501,6 +502,11 @@ the InterLisp Standard.")
                 (sha256
                  (base32
                   "04rnwllxnl86zw8c6pwxznn49bvkvh0f1lfliy085vjzvlq3rgja"))))
+      ;; See "utils.h" for supported systems. Upstream bug:
+      ;; https://github.com/JeffBezanson/femtolisp/issues/25
+      (supported-systems
+       (fold delete %supported-systems
+             '("armhf-linux" "mips64el-linux")))
       (build-system gnu-build-system)
       (arguments
        `(#:make-flags '("CC=gcc" "release")