summary refs log tree commit diff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2019-10-03 14:11:28 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-10-06 14:28:51 +0200
commit2601da052314ee399711e34a1e5d958a14c2725b (patch)
treed0a31e494a7a7c4644ee22f47b7bbd5c64a77d97 /gnu/packages/lisp.scm
parent7273b3b2a666b470fe508ae3221d9b93b60a4f15 (diff)
downloadguix-2601da052314ee399711e34a1e5d958a14c2725b.tar.gz
gnu: Add cl-store.
* gnu/packages/lisp.scm (sbcl-cl-store, cl-store, ecl-cl-store): New
  variables.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index cc181dca06..007cdb7e0e 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -7402,3 +7402,35 @@ threads.")
          ;; Disable the tests for now, as the SEND-SEQUENCE test seems to
          ;; never end.
          ((#:tests? _ #f) #f))))))
+
+(define-public sbcl-cl-store
+  (let ((commit "cd01f2610d3360dc01ab972bd9317407aaea7745")
+        (revision "0"))
+    (package
+      (name "sbcl-cl-store")
+      (version (git-version "0.8.11" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/skypher/cl-store.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "05b7kh5af2ax7vlmphpac4vbqr84j5ivppj96qzb64fxpjpqglm4"))))
+      (build-system asdf-build-system/sbcl)
+      (native-inputs
+       `(("rt" ,sbcl-rt)))
+      (synopsis "Common Lisp library to serialize data")
+      (description
+       "CL-STORE is a portable serialization package which should give you the
+ability to store all Common Lisp data types into streams.")
+      (home-page "http://www.common-lisp.net/project/cl-store/")
+      (license license:expat))))
+
+(define-public cl-store
+  (sbcl-package->cl-source-package sbcl-cl-store))
+
+(define-public ecl-cl-store
+  (sbcl-package->ecl-package sbcl-cl-store))