summary refs log tree commit diff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2018-12-18 21:17:16 +0000
committerChristopher Lemmer Webber <cwebber@dustycloud.org>2018-12-19 09:45:39 -0500
commitdba83d7d14f8649932ed9e9900fbc8421ed39858 (patch)
tree793abdf4c7ecf3c4132daf0620dbf916f0a9e4cd /gnu/packages/lisp.scm
parent38abef124bc18d3834eb12352a974b6143f62e97 (diff)
downloadguix-dba83d7d14f8649932ed9e9900fbc8421ed39858.tar.gz
gnu: stumpwm: Fix gnew command.
The new release of StumpWM broken the interactive 'gnew' command.  It was
fixed upstream [0] and will be part of the next release.

0: https://github.com/stumpwm/stumpwm/pull/538

* gnu/packages/patches/stumpwm-fix-broken-read-one-line.patch: New file.
* gnu/packages/lisp.scm (stumpwm)[source]: Use it.
* gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index d8da2951df..e4669e34f4 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -976,7 +976,9 @@ from other CLXes around the net.")
                     version ".tar.gz"))
               (sha256
                (base32 "177gxfk4c127i9crghx6fmkipznhgylvzgnjb2pna38g21gg6s39"))
-              (file-name (string-append "stumpwm-" version ".tar.gz"))))
+              (file-name (string-append "stumpwm-" version ".tar.gz"))
+              (patches
+               (search-patches "stumpwm-fix-broken-read-one-line.patch"))))
     (build-system asdf-build-system/sbcl)
     (native-inputs `(("fiasco" ,sbcl-fiasco)))
     (inputs `(("cl-ppcre" ,sbcl-cl-ppcre)