summary refs log tree commit diff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-04-14 18:54:52 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-04-14 20:23:22 +0200
commiteaa668ddda04e877d186203175fa36db4d1121bf (patch)
treecd212ff502f86ac019879d1bfa50d899dafb9b94 /gnu/packages/lisp.scm
parent92e52d25adbb684ae943be396ee27273d9475afc (diff)
downloadguix-eaa668ddda04e877d186203175fa36db4d1121bf.tar.gz
gnu: txr: Update to 235.
* gnu/packages/lisp.scm (txr): Update to 235.
[arguments]: Cosmetic shortening.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index d7ad0a0db0..27d38cd471 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -845,7 +845,7 @@ enough to play the original mainframe Zork all the way through.")
 (define-public txr
   (package
     (name "txr")
-    (version "234")
+    (version "235")
     (source
      (origin
        (method git-fetch)
@@ -854,8 +854,7 @@ enough to play the original mainframe Zork all the way through.")
              (commit (string-append "txr-" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32
-         "0c9qsj4xwc24c9g02mr5n97m4d87d4n0pcc2c2n58l2vg5dnzba0"))))
+        (base32 "0kpqk2x0sz7sqxsrhasq0xnljjlnxwhh4xjx2nii0zy2jkv4vsbn"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags
@@ -873,9 +872,8 @@ enough to play the original mainframe Zork all the way through.")
              #t))
          (add-after 'configure 'fix-tests
            (lambda _
-             (substitute* "tests/017/realpath.tl"
-               (("/usr/bin") "/"))
-             (substitute* "tests/017/realpath.expected"
+             (substitute* (list "tests/017/realpath.tl"
+                                "tests/017/realpath.expected")
                (("/usr/bin") "/"))
              #t)))))
     (native-inputs