summary refs log tree commit diff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-07-05 22:29:47 +0200
committerLudovic Courtès <ludo@gnu.org>2019-07-05 22:30:27 +0200
commitcce7b037084fe6680803850aed249950e0fdba09 (patch)
treeea1e3008bccc2771ec295156ab0676f1551bc23e /gnu/packages/lisp.scm
parent6b4a4318434522372a5f2c7476fbc1bacbcee278 (diff)
downloadguix-cce7b037084fe6680803850aed249950e0fdba09.tar.gz
Revert "gnu: Add sbcl-cl-xmlspam."
The sbcl-cl-xmlspam package currently has no license information, which
makes it non-free.

Furthermore, the invalid 'license' field prevents evaluation from
completing.

This reverts commit ec982546941b59fdd14e0b08f023baf2e75d71a3.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 64e5a16939..3aa2429595 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -6579,32 +6579,3 @@ This system contains the CFFI foreign slot access extension.")))
     (description "Trivia is a pattern matching compiler that is compatible
 with Optima, another pattern matching library for Common Lisp.  It is meant to
 be faster and more extensible than Optima.")))
-
-(define-public sbcl-cl-xmlspam
-  (package
-    (name "sbcl-cl-xmlspam")
-    (build-system asdf-build-system/sbcl)
-    (version "0.0.0")
-    (home-page "https://common-lisp.net/project/cl-xmlspam/")
-    (source
-     (origin
-       (method url-fetch)
-       (uri "http://common-lisp.net/project/cl-xmlspam/cl-xmlspam.tgz")
-       (file-name (string-append name "-" version))
-       (sha256
-        (base32
-         "0r0pjh1yjcj2izxlbd3f3bwfwxllhag56wz8ijdl6442pf3gdazh"))))
-    (inputs
-     `(("cxml" ,sbcl-cxml)
-       ("cl-ppcre" ,sbcl-cl-ppcre)))
-    (synopsis "Concise, regexp-like pattern matching on streaming XML for Common Lisp")
-    (description "CXML does an excellent job at parsing XML elements, but what
-do you do when you have a XML file that's larger than you want to fit in
-memory, and you want to extract some information from it?  Writing code to deal
-with SAX events, or even using Klacks, quickly becomes tedious.
-@code{cl-xmlspam} (for XML Stream PAttern Matcher) is designed to make it easy
-to write code that mirrors the structure of the XML that it's parsing.  It
-also makes it easy to shift paradigms when necessary - the usual Lisp control
-constructs can be used interchangeably with pattern matching, and the full
-power of CXML is available when necessary.")
-    (license #f)))