summary refs log tree commit diff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-07-11 12:03:40 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-07-11 12:21:00 -0400
commit15f9870eb36e688fac2af37828971779b6c56916 (patch)
tree00e27cf2624149a68b04c3723529a729993a5736 /gnu/packages/llvm.scm
parent0cce3ac36e7acdf7502a9d8dd313bf40055e1484 (diff)
downloadguix-15f9870eb36e688fac2af37828971779b6c56916.tar.gz
gnu: rocm: Update to 5.6.0.
Update all of the ROCm packages at the same time as they share a version
number and should be upgraded together, including llvm-for-rocm.

* gnu/packages/llvm.scm (llvm-for-rocm): Update to 5.6.0.
[source]{patches}: Remove unneeded patches (linkdl and remove-isystem-usr-include).
* gnu/packages/rocm.scm (rocm-cmake, roct-thunk-interface): Update
to 5.6.0.
(rocclr-src): Update to 5.6.0.
[source]{patches}: Add enable-gfx800 patch.
(rocm-device-libs):  Update to 5.6.0.
[inputs]: Update style.
(rocm-comgr): Update to 5.6.0.
[inputs]: Remove lld.  Update style.
(rocr-runtime): Update to 5.6.0.
[arguments]: Use gexps.  Remove configure-flags.  Add add-rocm-device-lib-path
phase.
[inputs]: Add libdrm.  Update style.
[native-inputs]: Add pkg-config.  Update style.
(rocm-opencl-runtime): Update to 5.6.0.
[source]{patches}: Remove noopencl patch.
[arguments]{configure-flags}: Add BUILD_ICD=OFF and
FILE_REORG_BACKWARD_COMPATIBILITY=OFF flags.
[inputs]: Add opencl-headers.
(rocminfo): Update to 5.6.0.
[arguments]: Use gexps.  Use search-input-file instead of assoc-ref and which.
(rocm-bandwidth-test): Update to 5.6.0.
[source]{patches}: Add fix-includes patch.
* gnu/packages/patches/rocm-comgr-3.1.0-dependencies.patch,
gnu/packages/patches/rocm-opencl-runtime-4.3-noclinfo.patch: Update patches.
* gnu/packages/patches/llvm-roc-4.0.0-remove-isystem-usr-include.patch,
gnu/packages/patches/llvm-roc-5.0.0-linkdl.patch,
gnu/packages/patches/rocm-opencl-runtime-4.3-noopencl.patch: Delete files.
* gnu/packages/patches/rocm-bandwidth-test-5.5.0-fix-includes.patch,
gnu/packages/patches/rocclr-5.6.0-enable-gfx800.patch: New files.
* gnu/local.mk (dist_patch_DATA): Update patches.
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 6d83313af6..de5ad3718b 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1462,7 +1462,7 @@ Library.")
     ;; Based on LLVM 14 as of v5.0.0
     (inherit llvm-14)
     (name "llvm-for-rocm")
-    (version "5.1.3")                         ;this must match '%rocm-version'
+    (version "5.6.0")                         ;this must match '%rocm-version'
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1471,10 +1471,7 @@ Library.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0j6ydfkwrxwskgnhxc3cmry42n5faqbnwf2747qgf7lz5id8h8g5"))
-              (patches
-               (search-patches "llvm-roc-5.0.0-linkdl.patch"
-                               "llvm-roc-4.0.0-remove-isystem-usr-include.patch"))))
+                "1kg6q6aqijjrwaznj0gr3nd01gykrnqqnk8vz8wyfifr18l9jrgx"))))
     (arguments
      (substitute-keyword-arguments (package-arguments llvm-14)
        ((#:configure-flags flags)