summary refs log tree commit diff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-04-24 13:04:55 +0200
committerMarius Bakke <marius@gnu.org>2021-04-28 17:59:32 +0200
commit8fa86141b709195a44f8fbf8fa19c6e877f6c8a2 (patch)
treeee61415f963b213bdf05e52ef563b626d02b6651 /gnu/packages/llvm.scm
parent01e33a031e493477d930b9383d397fea012a3b1a (diff)
downloadguix-8fa86141b709195a44f8fbf8fa19c6e877f6c8a2.tar.gz
gnu: LLVM, Clang: Add 12.0.0.
* gnu/packages/patches/clang-12-tools-extra-directory.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/llvm.scm (llvm-12, clang-runtime-12, clang-12,
clang-toolchain-12): New variables.
(llvm-11): Inherit from LLVM-12.
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm47
1 files changed, 43 insertions, 4 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 605bd8629a..b510f319f9 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -476,21 +476,21 @@ output), and Binutils.")
               ("libc-debug" ,glibc "debug")
               ("libc-static" ,glibc "static")))))
 
-(define-public llvm-11
+(define-public llvm-12
   (package
     (name "llvm")
-    (version "11.0.0")
+    (version "12.0.0")
     (source
      (origin
       (method url-fetch)
       (uri (llvm-uri "llvm" version))
       (sha256
        (base32
-        "0s94lwil98w7zb7cjrbnxli0z7gklb312pkw74xs1d6zk346hgwi"))))
+        "0l4b79gwfvxild974aigcq1yigypjsk2j5p59syhl6ksd744gp29"))))
     (build-system cmake-build-system)
     (outputs '("out" "opt-viewer"))
     (native-inputs
-     `(("python" ,python-2) ;bytes->str conversion in clang>=3.7 needs python-2
+     `(("python" ,python)
        ("perl"   ,perl)))
     (inputs
      `(("libffi" ,libffi)))
@@ -538,6 +538,45 @@ languages is in development.  The compiler infrastructure includes mirror sets
 of programming tools as well as libraries with equivalent functionality.")
     (license license:asl2.0)))  ;with LLVM exceptions, see LICENSE.txt
 
+(define-public clang-runtime-12
+  (clang-runtime-from-llvm
+   llvm-12
+   "0d444qihq9jhqnfv003cr704v363va72zl6qaw2algj1c85cva45"))
+
+(define-public clang-12
+  (clang-from-llvm llvm-12 clang-runtime-12
+                   "1vd9rhhrd8ghdg111lac7w8by71y9l14yh5zxfijsm6lj4p4avp2"
+                   #:patches '("clang-11.0-libc-search-path.patch")
+                   #:tools-extra
+                   (origin
+                     (method url-fetch)
+                     (uri (llvm-uri "clang-tools-extra"
+                                    (package-version llvm-12)))
+                     (patches
+                      (search-patches "clang-12-tools-extra-directory.patch"))
+                     (sha256
+                      (base32
+                       "0p3dzr0qa7mar83y66xa5m5apynf6ia0lsdsq6axwnm64ysy0hdd")))))
+
+(define-public clang-toolchain-12
+  (make-clang-toolchain clang-12))
+
+(define-public llvm-11
+  (package
+    (inherit llvm-12)
+    (version "11.0.0")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (llvm-uri "llvm" version))
+      (sha256
+       (base32
+        "0s94lwil98w7zb7cjrbnxli0z7gklb312pkw74xs1d6zk346hgwi"))))
+    (native-inputs
+     `(;; TODO: Switch to Python 3 in the next rebuild cycle.
+       ("python" ,python-2)
+       ("perl"   ,perl)))))
+
 (define-public clang-runtime-11
   (clang-runtime-from-llvm
    llvm-11