summary refs log tree commit diff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:11 +0200
commit7730b45bf8f456bece97135b244a26e41df00838 (patch)
tree0ff1d5d4f1c79881050fa887757de0d86b9a4f8e /gnu/packages/llvm.scm
parenta8a3d31dec5d24b67ae09cb10fd5e49c684ae314 (diff)
downloadguix-7730b45bf8f456bece97135b244a26e41df00838.tar.gz
gnu: clang@14: Include the extras.
* gnu/packages/llvm.scm (clang-14): Add a matching #:tools-extra origin.

Reported by foobarxyz on #guix.
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 4d5a948236..c93c1db7fe 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -627,7 +627,16 @@ of programming tools as well as libraries with equivalent functionality.")
          ,@(package-native-inputs template))))))
 
 (define-public clang-14
-  (let ((template (clang-from-llvm llvm-14 clang-runtime-14)))
+  (let ((template
+         (clang-from-llvm llvm-14 clang-runtime-14
+                          #:tools-extra
+                          (origin
+                            (method url-fetch)
+                            (uri (llvm-uri "clang-tools-extra"
+                                           (package-version llvm-14)))
+                            (sha256
+                             (base32
+                              "188hh6l956gkl6hgjzzdraj5jp538zhhhllxvy23gml6slrmbj7j"))))))
     (package
       (inherit template)
       (arguments