summary refs log tree commit diff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-11 16:18:24 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-11 16:19:59 +0100
commit89c7894805329023754512c9b30e67ceb1753cb0 (patch)
tree505cb95f51c0e90cc09ac2bb4a912a182943feb6 /gnu/packages/llvm.scm
parent37a350eccee7b36cba779c6a6841448b8deaed72 (diff)
downloadguix-89c7894805329023754512c9b30e67ceb1753cb0.tar.gz
gnu: faust-2: Update to 2.5.23.
* gnu/packages/audio.scm (faust-2): Update to 2.5.23.
[native-inputs]: Replace llvm-with-rtti with llvm-3.8-with-rtti.
* gnu/packages/llvm.scm (llvm-with-rtti): Rename this variable...
(llvm-3.8-with-rtti): ...to this variable; inherit from llvm-3.8.
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index d0791d00cc..a809180e29 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -90,17 +90,6 @@ languages is in development.  The compiler infrastructure includes mirror sets
 of programming tools as well as libraries with equivalent functionality.")
     (license license:ncsa)))
 
-(define-public llvm-with-rtti
-  (package (inherit llvm)
-    (name "llvm-with-rtti")
-    (arguments
-     (substitute-keyword-arguments (package-arguments llvm)
-       ((#:configure-flags flags)
-        `(append '("-DCMAKE_SKIP_BUILD_RPATH=FALSE"
-                   "-DCMAKE_BUILD_WITH_INSTALL_RPATH=FALSE"
-                   "-DLLVM_REQUIRES_RTTI=1")
-                 ,flags))))))
-
 (define* (clang-runtime-from-llvm llvm hash
                                   #:optional (patches '()))
   (package
@@ -290,6 +279,18 @@ code analysis tools.")
        (base32
         "1ybmnid4pw2hxn12ax5qa5kl1ldfns0njg8533y3mzslvd5cx0kf"))))))
 
+;; This is for Faust 2
+(define-public llvm-3.8-with-rtti
+  (package (inherit llvm-3.8)
+    (name "llvm-with-rtti")
+    (arguments
+     (substitute-keyword-arguments (package-arguments llvm)
+       ((#:configure-flags flags)
+        `(append '("-DCMAKE_SKIP_BUILD_RPATH=FALSE"
+                   "-DCMAKE_BUILD_WITH_INSTALL_RPATH=FALSE"
+                   "-DLLVM_REQUIRES_RTTI=1")
+                 ,flags))))))
+
 (define-public clang-runtime-3.8
   (clang-runtime-from-llvm
    llvm-3.8