summary refs log tree commit diff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-12-13 11:39:21 +0100
committerRutger Helling <rhelling@mykolab.com>2018-12-13 11:39:57 +0100
commitd022c204bd21f3e0787b9fe158eaf395ffe26227 (patch)
tree3930e7bd3b943e5a18000c6c73050118e9e504d9 /gnu/packages/llvm.scm
parentb42b5afdf4040939f5b1648664400b0c75935c73 (diff)
downloadguix-d022c204bd21f3e0787b9fe158eaf395ffe26227.tar.gz
gnu: Add llvm@7.0.0.
* gnu/packages/llvm.scm (llvm@7.0.0): New variable.
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 8a9d1d312b..7eb785c364 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -95,6 +95,21 @@ languages is in development.  The compiler infrastructure includes mirror sets
 of programming tools as well as libraries with equivalent functionality.")
     (license license:ncsa)))
 
+;; TODO: Build Mesa with LLVM 7 in the next staging cycle.
+;; TODO: Make LLVM 7 the default LLVM once Clang is also upgraded.
+(define-public llvm-7.0.0
+  (package (inherit llvm)
+    (name "llvm")
+    (version "7.0.0")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "http://llvm.org/releases/"
+                          version "/llvm-" version ".src.tar.xz"))
+      (sha256
+       (base32
+        "08p27wv1pr9ql2zc3f3qkkymci46q7myvh8r5ijippnbwr2gihcb"))))))
+
 ;; FIXME: This package is here to prevent many rebuilds on x86_64 and i686
 ;; from commit fc9dbf41311d99d0fd8befc789ea7c0e35911890.  Update users of
 ;; this in the next rebuild cycle.