summary refs log tree commit diff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-10-18 17:32:24 +0200
committerMarius Bakke <marius@gnu.org>2020-10-19 00:12:31 +0200
commitdcafa89cf0b9124d0567264eb2ef4d730b1e75bb (patch)
treee0136b14f7390f81a6be1592f97d6e67df3b6a10 /gnu/packages/llvm.scm
parentd76b668cd6595d08761fa75d749ec943e792ea6f (diff)
downloadguix-dcafa89cf0b9124d0567264eb2ef4d730b1e75bb.tar.gz
gnu: extempore: Inline custom package variants.
Except novel ones without suitable replacements in Guix.

* gnu/packages/music.scm (portmidi-for-extempore): Remove variable, and move
to ...
(extempore)[inputs]: ... here.
* gnu/packages/llvm.scm (llvm-for-extempore): Likewise.
* gnu/packages/image.scm (stb-image-for-extempore): Likewise.
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm14
1 files changed, 0 insertions, 14 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 358fbfff0a..147247331e 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -821,20 +821,6 @@ components which highly leverage existing libraries in the larger LLVM Project."
                    "0846h8vn3zlc00jkmvrmy88gc6ql6014c02l4jv78fpvfigmgssg"
                    #:patches '("clang-3.5-libc-search-path.patch")))
 
-(define-public llvm-for-extempore
-  (package (inherit llvm-3.8)
-    (name "llvm-for-extempore")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "http://extempore.moso.com.au/extras/"
-                           "llvm-3.8.0.src-patched-for-extempore.tar.xz"))
-       (sha256
-        (base32
-         "1svdl6fxn8l01ni8mpm0bd5h856ahv3h9sdzgmymr6fayckjvqzs"))))
-    ;; Extempore refuses to build on architectures other than x86_64
-    (supported-systems '("x86_64-linux"))))
-
 (define-public libcxx
   (package
     (name "libcxx")