summary refs log tree commit diff
path: root/gnu/packages/lolcode.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-03 05:19:21 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-03 06:38:56 +0100
commit9ae99a69c083868aa52826fe7e8e54a3b96ad3cb (patch)
tree1566d6a0c886c451626481abdf60b155e5d1e635 /gnu/packages/lolcode.scm
parent104264cd3a49fab79cdb55585922e6694e109b17 (diff)
downloadguix-9ae99a69c083868aa52826fe7e8e54a3b96ad3cb.tar.gz
gnu: lci: Don't use unstable tarball.
* gnu/packages/lolcode.scm (lci)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/lolcode.scm')
-rw-r--r--gnu/packages/lolcode.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/lolcode.scm b/gnu/packages/lolcode.scm
index e55a36c509..84ae83dcc8 100644
--- a/gnu/packages/lolcode.scm
+++ b/gnu/packages/lolcode.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 ng0 <ng0@n0.is>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,7 +22,7 @@
   #:use-module (gnu packages python)
   #:use-module (gnu packages readline)
   #:use-module (guix build-system cmake)
-  #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages))
 
@@ -29,19 +30,20 @@
   (package
     (name "lci")
     (version "0.11.2")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/justinmeza/lci/archive/v"
-                                  version ".tar.gz"))
-              (sha256
-               (base32
-                "1li7ikcrs7wqah7gqkirg0k61n6pm12w7pydin966x1sdn9na46b"))
-              (file-name (string-append name "-" version ".tar.gz"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/justinmeza/lci.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0syw60b93iajgh91ffchirwwhm2kix2753ibx845kyrhzggmdh2l"))))
     (build-system cmake-build-system)
     (inputs
      `(("readline" ,readline)))
     (native-inputs
-     `(("python-2" ,python-2))) ; for the tests
+     `(("python-2" ,python-2)))         ; for the tests
     (synopsis "LOLCODE interpreter written in C")
     (description
      "@code{lci} is a LOLCODE interpreter written in C and is designed to be