summary refs log tree commit diff
path: root/gnu/packages/lsh.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-06-27 22:27:26 +0200
committerLudovic Courtès <ludo@gnu.org>2013-06-27 22:27:26 +0200
commit96a8259a9dc8239bd340dc35ea4ebed82ed33d5e (patch)
tree26835dd06b4e4fccf59e296f78958193c473c4d6 /gnu/packages/lsh.scm
parent6e1c4093d27c3d57261958df6c04996c19c74e69 (diff)
downloadguix-96a8259a9dc8239bd340dc35ea4ebed82ed33d5e.tar.gz
gnu: lsh: Upgrade to 2.1.
* gnu/packages/lsh.scm (lsh): Upgrade to 2.1.  Add Nettle as an input.
  Remove now unneeded patches.
* gnu/packages/patches/lsh-guile-compat.patch,
  gnu/packages/patches/lsh-no-root-login.patch,
  gnu/packages/patches/lsh-pam-service-name.patch: Remove.
* gnu-system.am (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/lsh.scm')
-rw-r--r--gnu/packages/lsh.scm20
1 files changed, 7 insertions, 13 deletions
diff --git a/gnu/packages/lsh.scm b/gnu/packages/lsh.scm
index c031b287a1..a53e0f132f 100644
--- a/gnu/packages/lsh.scm
+++ b/gnu/packages/lsh.scm
@@ -24,6 +24,7 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages m4)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages nettle)
   #:use-module ((gnu packages compression)
                 #:renamer (symbol-prefix-proc 'guix:))
   #:use-module (gnu packages multiprecision)
@@ -52,7 +53,7 @@
 (define-public lsh
   (package
     (name "lsh")
-    (version "2.0.4")
+    (version "2.1")
     (source
      (origin
       (method url-fetch)
@@ -60,10 +61,11 @@
                           version ".tar.gz"))
       (sha256
        (base32
-        "149hf49xcj99wwvi7hcb59igq4vpyv8har1br1if3lrsw5irsjv1"))))
+        "1qqjy9zfzgny0rkb27c8c7dfsylvb6n0ld8h3an2r83pmaqr9gwb"))))
     (build-system gnu-build-system)
     (inputs
-     `(("linux-pam" ,linux-pam)
+     `(("nettle" ,nettle)
+       ("linux-pam" ,linux-pam)
        ("m4" ,m4)
        ("readline" ,readline)
        ("liboop" ,liboop)
@@ -72,17 +74,9 @@
        ("guile" ,guile-final)
        ("gperf" ,gperf)
        ("psmisc" ,psmisc)                         ; for `killall'
-
-       ("patch/no-root-login" ,(search-patch "lsh-no-root-login.patch"))
-       ("patch/guile-compat" ,(search-patch "lsh-guile-compat.patch"))
-       ("patch/pam-service-name"
-        ,(search-patch "lsh-pam-service-name.patch"))))
+       ))
     (arguments
-     '(#:patches (list (assoc-ref %build-inputs "patch/no-root-login")
-                       (assoc-ref %build-inputs "patch/pam-service-name")
-                       (assoc-ref %build-inputs "patch/guile-compat"))
-
-       ;; Skip the `configure' test that checks whether /dev/ptmx &
+     '(;; Skip the `configure' test that checks whether /dev/ptmx &
        ;; co. work as expected, because it relies on impurities (for
        ;; instance, /dev/pts may be unavailable in chroots.)
        #:configure-flags '("lsh_cv_sys_unix98_ptys=yes")