summary refs log tree commit diff
path: root/gnu/packages/lsof.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-04-29 23:39:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-04-29 23:41:05 +0300
commit4ae3549f7cd57ecd09ebd957ec512dd530dc83d0 (patch)
tree777f01a28ec6ab29b73a027f71ce3b661119f3ab /gnu/packages/lsof.scm
parentb6ea329a32f1d1da17ff72affab2e1fe16aff51f (diff)
downloadguix-4ae3549f7cd57ecd09ebd957ec512dd530dc83d0.tar.gz
gnu: lsof: Shorten 'install phase.
* gnu/packages/lsof.scm (lsof)[arguments]: Use 'install-file during the
'install phase.
Diffstat (limited to 'gnu/packages/lsof.scm')
-rw-r--r--gnu/packages/lsof.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index 97658c856a..5442936a49 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -72,13 +72,9 @@
         (replace 'install
           (lambda* (#:key outputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out")))
-              (mkdir out)
-              (mkdir (string-append out "/bin"))
-              (copy-file "lsof" (string-append out "/bin/lsof"))
-              (mkdir (string-append out "/share"))
-              (mkdir (string-append out "/share/man"))
-              (mkdir (string-append out "/share/man/man8"))
-              (copy-file "lsof.8" (string-append out "/share/man/man8/lsof.8"))))))))
+              (install-file "lsof" (string-append out "/bin"))
+              (install-file "lsof.8" (string-append out "/share/man/man8")))
+            #t)))))
    (synopsis "Display information about open files")
    (description
     "Lsof stands for LiSt Open Files, and it does just that.