summary refs log tree commit diff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-08-22 21:33:13 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-08-28 12:41:27 +0200
commitd62dc2aec2c04780a26620e38f218e359e93fbf8 (patch)
treeb2370b68b6ea2615925f4f023f3d166898778d49 /gnu/packages/lua.scm
parent182de8fcdd9863bedff51e34bb384f68e55029c8 (diff)
downloadguix-d62dc2aec2c04780a26620e38f218e359e93fbf8.tar.gz
gnu: Add lua5.1-sec.
* gnu/packages/lua.scm (lua5.1-sec): New variable.
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index cfa5d2b876..8bd67c594d 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -28,6 +28,7 @@
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
   #:use-module (gnu packages readline)
+  #:use-module (gnu packages tls)
   #:use-module (gnu packages xml))
 
 (define-public lua
@@ -222,3 +223,39 @@ set of functions related to file systems offered by the standard Lua
 distribution.  LuaFileSystem offers a portable way to access the underlying
 directory structure and file attributes.")
     (license (package-license lua-5.1))))
+
+(define-public lua5.1-sec
+  (package
+    (name "lua5.1-sec")
+    (version "0.6")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/brunoos/luasec/archive/"
+                                  "luasec-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0pgd1anzznl4s0h16wg8dlw9mgdb9h52drlcki6sbf5y31fa7wyf"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags
+       (let ((out (assoc-ref %outputs "out")))
+         (list "linux"
+               "CC=gcc"
+               "LD=gcc"
+               (string-append "LUAPATH=" out "/share/lua/5.1")
+               (string-append "LUACPATH=" out "/lib/lua/5.1")))
+       #:tests? #f ; no tests included
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))
+    (inputs
+     `(("lua" ,lua-5.1)
+       ("openssl" ,openssl)))
+    (propagated-inputs
+     `(("lua-socket" ,lua5.1-socket)))
+    (home-page "https://github.com/brunoos/luasec/wiki")
+    (synopsis "OpenSSL bindings for Lua")
+    (description "LuaSec is a binding for OpenSSL library to provide TLS/SSL
+communication.  It takes an already established TCP connection and creates a
+secure session between the peers.")
+    (license (package-license lua-5.1))))