summary refs log tree commit diff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2019-01-08 13:49:29 +0100
committerClément Lassieur <clement@lassieur.org>2019-01-08 15:23:36 +0100
commitd994325747486e7beddbf03255c8c95d58d08dc8 (patch)
tree8b32defb44a62fe4686de397870facdd0f347673 /gnu/packages/lua.scm
parent253aab77c5e62a977be78fdb2d7af6b30632fb8b (diff)
downloadguix-d994325747486e7beddbf03255c8c95d58d08dc8.tar.gz
gnu: Add lua-filesystem and lua5.2-filesystem.
* gnu/packages/lua.scm (lua-filesystem, lua5.2-filesystem): New variables.
(make-lua-filesystem): New procedure.
(lua-filesystem, lua5.1-filesystem, lua5.2-filesystem): Call it.
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm20
1 files changed, 16 insertions, 4 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 3669aafad5..5e73f1ed89 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -244,9 +244,9 @@ handy.")
 (define-public lua5.2-socket
   (make-lua-socket "lua5.2-socket" lua-5.2))
 
-(define-public lua5.1-filesystem
+(define (make-lua-filesystem name lua)
   (package
-    (name "lua5.1-filesystem")
+    (name name)
     (version "1.6.3")
     (source (origin
               (method url-fetch)
@@ -260,13 +260,16 @@ handy.")
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags
-       (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       (let ((out (assoc-ref %outputs "out"))
+             (lua-version ,(version-major+minor (package-version lua))))
+         (list (string-append "PREFIX=" out)
+               (string-append "LUA_LIBDIR=" out "/lib/lua/" lua-version)))
        #:test-target "test"
        #:phases
        (modify-phases %standard-phases
          (delete 'configure))))
     (inputs
-     `(("lua" ,lua-5.1)))
+     `(("lua" ,lua)))
     (home-page "https://keplerproject.github.io/luafilesystem/index.html")
     (synopsis "File system library for Lua")
     (description "LuaFileSystem is a Lua library developed to complement the
@@ -275,6 +278,15 @@ distribution.  LuaFileSystem offers a portable way to access the underlying
 directory structure and file attributes.")
     (license (package-license lua-5.1))))
 
+(define-public lua-filesystem
+  (make-lua-filesystem "lua-filesystem" lua))
+
+(define-public lua5.1-filesystem
+  (make-lua-filesystem "lua5.1-filesystem" lua-5.1))
+
+(define-public lua5.2-filesystem
+  (make-lua-filesystem "lua5.2-filesystem" lua-5.2))
+
 (define-public lua5.1-sec
   (package
     (name "lua5.1-sec")