summary refs log tree commit diff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-01-25 09:57:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-01-25 09:57:18 +0200
commitd49b0331e161271e5967a156e26eefd2c5abfcb4 (patch)
tree9adbeb53f40f0042ee2831d8e81bc9a7b695e72b /gnu/packages/lua.scm
parentffd5ec05db3e98aa4c7665e6cb9483148e3c37e5 (diff)
downloadguix-d49b0331e161271e5967a156e26eefd2c5abfcb4.tar.gz
gnu: fennel: Update to 0.8.0.
* gnu/packages/lua.scm (fennel): Update to 0.8.0.
[arguments]: Move 'check phase to after 'install phase.
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 950090afcb..e28dde62d7 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -3,7 +3,7 @@
 ;;; Copyright © 2014 Raimon Grau <raimonster@gmail.com>
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2016, 2017, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016 doncatnip <gnopap@gmail.com>
 ;;; Copyright © 2016, 2017, 2019 Clément Lassieur <clement@lassieur.org>
@@ -1066,7 +1066,7 @@ shell command executions.")
 (define-public fennel
   (package
     (name "fennel")
-    (version "0.7.0")
+    (version "0.8.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1075,7 +1075,7 @@ shell command executions.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "17pdcwhfw754fblppw46qphnsvxrn3b7066cz54lv8c0c12iryim"))
+                "1jng33vmnk6mi37l3x2z0plng940jpj7kz1s493ki80z3mkaxjfg"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -1091,7 +1091,10 @@ shell command executions.")
            (lambda _
              (substitute* "fennel"
                (("/usr/bin/env lua") (which "lua")))
-             #t)))))
+             #t))
+         (delete 'check)
+         (add-after 'install 'check
+           (assoc-ref %standard-phases 'check)))))
     (inputs `(("lua" ,lua)))
     (home-page "https://fennel-lang.org/")
     (synopsis "A Lisp that compiles to Lua")