summary refs log tree commit diff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-17 01:11:46 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-31 21:55:43 -0400
commit1ef04fb2288dade3ad2883026ae286a68ef13a1e (patch)
tree758d3f77c7d1e31ef3c394252180d3a5cb43b194 /gnu/packages/lxqt.scm
parent4af9984a4e77d42cd063de590c164044599b4062 (diff)
downloadguix-1ef04fb2288dade3ad2883026ae286a68ef13a1e.tar.gz
gnu: qtsvg: Rename variable to qtsvg-5.
This is in preparation of the qtsvg update to version 6.

This change was automated via the following command:

  git grep -l '\bqtsvg\b' | xargs sed 's/qtsvg/qtsvg-5/g' -i
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm40
1 files changed, 20 insertions, 20 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index a0a3a0f15b..9ff1de942c 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -187,7 +187,7 @@ itself as well as other components maintained by the LXQt project.")
              #t)))))
     (propagated-inputs
      ;; required by Qt5XdgIconLoader.pc
-     (list glib qtbase-5 qtsvg))
+     (list glib qtbase-5 qtsvg-5))
     (native-inputs
      (list lxqt-build-tools pkg-config))
     (home-page "https://github.com/lxqt/libqtxdg")
@@ -231,7 +231,7 @@ in Qt.")
            libqtxdg
            libxscrnsaver
            polkit-qt
-           qtsvg
+           qtsvg-5
            qtx11extras))
     (native-inputs
      (list lxqt-build-tools qttools))
@@ -284,7 +284,7 @@ and memory usage or network traffic.")
            liblxqt
            libqtxdg
            qtbase-5
-           qtsvg
+           qtsvg-5
            qtx11extras))
     (native-inputs
      (list lxqt-build-tools qttools))
@@ -326,7 +326,7 @@ LXQt and the system it's running on.")
            liblxqt
            libqtxdg
            polkit-qt
-           qtsvg
+           qtsvg-5
            qtx11extras))
     (native-inputs
      (list lxqt-build-tools qttools))
@@ -375,7 +375,7 @@ the operating system LXQt is running on.")
            libxcursor
            libxi
            qtbase-5
-           qtsvg
+           qtsvg-5
            qtx11extras
            solid
            xf86-input-libinput
@@ -443,7 +443,7 @@ configuration of both LXQt and the underlying operating system.")
            liblxqt
            libqtxdg
            qtbase-5
-           qtsvg
+           qtsvg-5
            qtx11extras))
     (native-inputs
      (list pkg-config qttools lxqt-build-tools))
@@ -489,7 +489,7 @@ as a whole and are not limited to distinct applications.")
            liblxqt
            libqtxdg
            qtbase-5
-           qtsvg
+           qtsvg-5
            qtx11extras))
     (native-inputs
      (list lxqt-build-tools qttools))
@@ -534,7 +534,7 @@ according to the Desktop Notifications Specification.")
            liblxqt
            libqtxdg
            qtbase-5
-           qtsvg
+           qtsvg-5
            qtx11extras))
     (native-inputs
      (list lxqt-build-tools qttools))
@@ -584,7 +584,7 @@ of other programs.")
            pcre
            pulseaudio
            qtbase-5
-           qtsvg
+           qtsvg-5
            qtx11extras
            solid
            xcb-util
@@ -646,7 +646,7 @@ of other programs.")
            pcre
            polkit-qt
            qtbase-5
-           qtsvg
+           qtsvg-5
            qtx11extras))
     (native-inputs
      (list pkg-config polkit lxqt-build-tools qttools))
@@ -692,7 +692,7 @@ LXQt.")
            libqtxdg
            lxqt-globalkeys
            qtbase-5
-           qtsvg
+           qtsvg-5
            qtx11extras
            solid))
     (native-inputs
@@ -739,7 +739,7 @@ when laptop batteries are low on power.")
            libfm-qt
            libqtxdg
            qtbase-5
-           qtsvg
+           qtsvg-5
            qtx11extras))
     (native-inputs
      (list lxqt-build-tools qttools))
@@ -779,7 +779,7 @@ Qt with LXQt.")
            muparser
            pcre
            qtbase-5
-           qtsvg
+           qtsvg-5
            qtx11extras))
     (native-inputs
      (list pkg-config qttools lxqt-build-tools))
@@ -825,7 +825,7 @@ allows for launching applications or shutting down the system.")
            libqtxdg
            procps
            qtbase-5
-           qtsvg
+           qtsvg-5
            qtx11extras
            xdg-user-dirs))
     (native-inputs
@@ -893,7 +893,7 @@ for the LXQt desktop environment.")
            liblxqt
            libqtxdg
            qtbase-5
-           qtsvg
+           qtsvg-5
            qtx11extras
            sudo))
     (native-inputs
@@ -1068,7 +1068,7 @@ manager Compton.")
         (base32 "0g6hs41xfw2ghhwpj0rqr2ciri0x9v984689yrnmnvah88zlya1f"))))
     (build-system cmake-build-system)
     (inputs
-     (list libexif libfm-qt qtbase-5 qtsvg qtx11extras))
+     (list libexif libfm-qt qtbase-5 qtsvg-5 qtx11extras))
     (native-inputs
      (list pkg-config lxqt-build-tools qttools))
     (arguments
@@ -1225,7 +1225,7 @@ QTermWidget.")
         (base32 "0cilzw7rz5m2klzpax7rrs5rr6whfda2svwzsn2jvmrirmh5by7r"))))
     (build-system cmake-build-system)
     (inputs
-     (list kwindowsystem libqtxdg qtbase-5 qtsvg qtx11extras))
+     (list kwindowsystem libqtxdg qtbase-5 qtsvg-5 qtx11extras))
     (native-inputs
      (list pkg-config perl qttools))
     (arguments
@@ -1283,7 +1283,7 @@ like @command{tar} and @command{zip}.")
       (inputs
         (list kwindowsystem
               qtbase-5
-              qtsvg
+              qtsvg-5
               liblxqt
               qtx11extras
               libqtxdg))
@@ -1332,9 +1332,9 @@ desktop.")
            xdg-user-dirs
            xdg-utils
            ;; Base
-           ;; TODO: qtsvg is needed for lxqt apps to display icons. Maybe it
+           ;; TODO: qtsvg-5 is needed for lxqt apps to display icons. Maybe it
            ;; should be added to their propagated-inputs?
-           qtsvg
+           qtsvg-5
            ;; Core
            lxqt-about
            lxqt-admin