summary refs log tree commit diff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-18 11:01:29 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-24 22:37:24 +0800
commitcc7f4175728a651b4a9763bd9e6c3c5b5a44c547 (patch)
treee7ecddc17d833055381dcdcd94bc30eaebf5f4f3 /gnu/packages/lxqt.scm
parentaf291d1cdf8f82bc00b25f1e62d3c4dcbda3a936 (diff)
downloadguix-cc7f4175728a651b4a9763bd9e6c3c5b5a44c547.tar.gz
gnu: Add lxqt-runner.
* gnu/packages/lxqt.scm (lxqt-runner): New variable.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index f112f52856..0253cb48fb 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -37,6 +37,7 @@
   #:use-module (gnu packages linux)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages lxde)
+  #:use-module (gnu packages maths)
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages polkit)
@@ -325,6 +326,51 @@ as a whole and are not limited to distinct applications.")
     (description "lxqt-panel represents the taskbar of LXQt.")
     (license lgpl2.1+)))
 
+(define-public lxqt-runner
+  (package
+    (name "lxqt-runner")
+    (version "0.13.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
+                           version "/" name "-" version ".tar.xz"))
+       (sha256
+        (base32 "0dsg6fdcqbl7gza0sg1pb49zn5x31q7zx77jp7mkf6wc2lv8lali"))))
+    (build-system cmake-build-system)
+    (inputs
+     `(("kwindowsystem" ,kwindowsystem)
+       ("liblxqt" ,liblxqt)
+       ("libqtxdg" ,libqtxdg)
+       ("lxqt-globalkeys" ,lxqt-globalkeys)
+       ("muparser" ,muparser)
+       ("pcre" ,pcre)
+       ("qtbase" ,qtbase)
+       ("qtsvg" ,qtsvg)
+       ("qtx11extras" ,qtx11extras)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("qttools", qttools)
+       ("lxqt-build-tools" ,lxqt-build-tools)))
+    (arguments
+     '(#:tests? #f                      ; no tests
+       #:configure-flags
+       ;; TODO: prefetch translations files from 'lxqt-l10n'.
+       '("-DPULL_TRANSLATIONS=NO")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-source
+           (lambda _
+             (substitute* '("autostart/CMakeLists.txt")
+               (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
+                "DESTINATION \"${CMAKE_INSTALL_PREFIX}/etc/xdg"))
+             #t)))))
+    (home-page "https://lxqt.org/")
+    (synopsis "Tool used to launch programs quickly by typing their names")
+    (description "lxqt-runner provides a GUI that comes up on the desktop and
+allows for launching applications or shutting down the system.")
+    (license lgpl2.1+)))
+
 (define-public lxqt-session
   (package
     (name "lxqt-session")