summary refs log tree commit diff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2021-05-17 00:06:15 +1000
committerLudovic Courtès <ludo@gnu.org>2021-05-29 20:16:50 +0200
commit3e294125c0c9ab789faa33fad53ea83c37774cb2 (patch)
tree3c8fb003dc8464dab4867c339d8be91ea2323d8d /gnu/packages/lxqt.scm
parent73c8bb7cd6ffa32e4462f933f2f21088506bc8f0 (diff)
downloadguix-3e294125c0c9ab789faa33fad53ea83c37774cb2.tar.gz
gnu: lxqt-connman-applet: Update to 0.15-db1618d5.
* gnu/packages/lxqt.scm (lxqt-connman-applet): Update to
0.15-db1618d5 (translation updates).
Untabify.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 0b815622d3..b5a549a7fc 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -1329,7 +1329,7 @@ like @command{tar} and @command{zip}.")
 (define-public lxqt-connman-applet
   ;; since the main developers didn't release any version yet,  their 
   ;; latest commit on `master` branch at the moment used for this version.
-  (let ((commit "8a6cc14371a2f18f963e6a2996446082bb60f17d")
+  (let ((commit "db1618d58fd3439142c4e44b24cba0dbb68b7141")
         (revision "0"))
     (package
       (name "lxqt-connman-applet")
@@ -1341,7 +1341,8 @@ like @command{tar} and @command{zip}.")
             (url (string-append "https://github.com/lxqt/" name))
             (commit commit)))
           (file-name (git-file-name name version))
-          (sha256 (base32 "0br4bxfrl8k7lq84aq4grznlk8xzzjgkmd19bf9mwjr0a87gg72v"))))
+          (sha256
+           (base32 "087641idpg7n8yhh5biis4wv52ayw3rddirwqb34bf5fwj664pw9"))))
       (build-system cmake-build-system)
       (inputs
         `(("kwindowsystem" ,kwindowsystem)
@@ -1365,13 +1366,13 @@ like @command{tar} and @command{zip}.")
                                     "/share/lxqt/translations"))
                     (("\\$\\{LXQT_ETC_XDG_DIR\\}") "etc/xdg"))
                   #t))
-	      (add-after 'unpack 'remove-definitions
-		(lambda _
-		  (substitute* "CMakeLists.txt"
-		    (("include\\(LXQtCompilerSettings NO_POLICY_SCOPE\\)")
-		     "include(LXQtCompilerSettings NO_POLICY_SCOPE)
+              (add-after 'unpack 'remove-definitions
+                (lambda _
+                  (substitute* "CMakeLists.txt"
+                    (("include\\(LXQtCompilerSettings NO_POLICY_SCOPE\\)")
+                     "include(LXQtCompilerSettings NO_POLICY_SCOPE)
 remove_definitions(-DQT_NO_CAST_TO_ASCII -DQT_NO_CAST_FROM_ASCII)"))
-		  #t)))))
+                  #t)))))
       (home-page "https://github.com/lxqt/lxqt-connman-applet")
       (synopsis "System-tray applet for connman")
       (description "This package provides a Qt-based system-tray applet for