summary refs log tree commit diff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo@riseup.net>2019-03-13 23:37:15 +0800
committerDanny Milosavljevic <dannym@scratchpost.org>2019-03-14 16:47:17 +0100
commitc1105c4bcf60dcc297d47268c96ad5f52971ac25 (patch)
tree4db2713bf539c32241d46a9b75597f67ee379d24 /gnu/packages/lxqt.scm
parent5b7a354d72a2ffe8162e4768530b86632eb32fe9 (diff)
downloadguix-c1105c4bcf60dcc297d47268c96ad5f52971ac25.tar.gz
gnu: libqtxdg: Update to 3.3.1.
* gnu/packages/lxqt.scm (libqtxdg): Update to 3.3.1.
[native-inputs]: Add lxqt-build-tools.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 6926d071d7..ebb1ff3096 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -157,7 +157,7 @@ itself as well as other components maintained by the LXQt project.")
 (define-public libqtxdg
   (package
     (name "libqtxdg")
-    (version "3.2.0")
+    (version "3.3.1")
     (source
      (origin
        (method url-fetch)
@@ -165,7 +165,7 @@ itself as well as other components maintained by the LXQt project.")
              "https://github.com/lxqt/libqtxdg/releases/download/"
              version "/libqtxdg-" version ".tar.xz"))
        (sha256
-        (base32 "0lq548pa69hfvnbj2ypba5ygm8n6v6g7bqqm8p5g538l1l3394cl"))))
+        (base32 "1mnnq8vbf5xjlrzajzfkay0yzzxri0zz0xi8x8rmxpw38xmglq8h"))))
     (build-system cmake-build-system)
     (arguments
      '(#:configure-flags
@@ -182,6 +182,8 @@ itself as well as other components maintained by the LXQt project.")
      ;; required by Qt5XdgIconLoader.pc
      `(("qtbase" ,qtbase)
        ("qtsvg" ,qtsvg)))
+    (native-inputs
+     `(("lxqt-build-tools" ,lxqt-build-tools)))
     (home-page "https://github.com/lxqt/libqtxdg")
     (synopsis "Qt implementation of freedesktop.org xdg specifications")
     (description "Libqtxdg implements the freedesktop.org xdg specifications