summary refs log tree commit diff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-18 15:11:10 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-25 21:34:55 +0800
commit8b1d43a75509366af9ea454ba8bf5b7658eef05c (patch)
tree91ef6d958b8666efab57069410f4fab2bf71aee9 /gnu/packages/lxqt.scm
parent5663b5b073ba51fd0c477be65c39d812aa5c1ce5 (diff)
downloadguix-8b1d43a75509366af9ea454ba8bf5b7658eef05c.tar.gz
gnu: Add lxqt-themes.
* gnu/packages/lxqt.scm (lxqt-themes): New variable.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 9e4e1dadfb..f1492e022e 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -429,6 +429,41 @@ shortcuts in LXQt sessions, that is shortcuts which apply to the LXQt session
 as a whole and are not limited to distinct applications.")
     (license license:lgpl2.1+)))
 
+(define-public lxqt-themes
+  (package
+    (name "lxqt-themes")
+    (version "0.13.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
+                           version "/" name "-" version ".tar.xz"))
+       (sha256
+        (base32 "13kkkzjx8bgnwckz79j273azvm4za66i4cp2qhxwdpxh0fwziklf"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("lxqt-build-tools" ,lxqt-build-tools)))
+    (arguments
+     `(#:tests? #f                      ; no tests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-source
+           (lambda _
+             (substitute* '("CMakeLists.txt")
+               (("DESTINATION \"\\$\\{LXQT_GRAPHICS_DIR\\}")
+                "DESTINATION \"${CMAKE_INSTALL_PREFIX}/share/lxqt/graphics"))
+             (substitute* '("themes/CMakeLists.txt")
+               (("DESTINATION \"\\$\\{LXQT_SHARE_DIR\\}")
+                "DESTINATION \"${CMAKE_INSTALL_PREFIX}/share/lxqt"))
+             #t)))))
+    (home-page "https://lxqt.org/")
+    (synopsis "Themes, graphics and icons for LXQt")
+    (description "This package comprises a number of graphic files and themes
+for LXQt.")
+    ;; The whole package is released under LGPL 2.1+, while the LXQt logo is
+    ;; licensed under CC-BY-SA 3.0.
+    (license license:lgpl2.1+)))
+
 (define-public lxqt-notificationd
   (package
     (name "lxqt-notificationd")