summary refs log tree commit diff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo@riseup.net>2019-03-13 23:37:24 +0800
committerDanny Milosavljevic <dannym@scratchpost.org>2019-03-14 16:47:17 +0100
commitc4a17525b9faf8993134c89966e3365c21e9fc50 (patch)
tree828ec4820ea333fa4f99d8bb1c9eb0bb06a64a60 /gnu/packages/lxqt.scm
parenta728afb63b93a690f415c73235acbf85698b13b7 (diff)
downloadguix-c4a17525b9faf8993134c89966e3365c21e9fc50.tar.gz
gnu: lxqt-panel: Update to 0.14.1.
* gnu/packages/lxqt.scm (lxqt-panel): Update to 0.14.1.
[arguments]: Remove #:configure-flags.
<#:phases>[patch-translations-dir]: New phase.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 43eaf23634..3802a6f212 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -543,14 +543,14 @@ of other programs.")
 (define-public lxqt-panel
   (package
     (name "lxqt-panel")
-    (version "0.13.0")
+    (version "0.14.1")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
                            version "/" name "-" version ".tar.xz"))
        (sha256
-        (base32 "1qraigzq7nc5a2q6f5ybxwx07gxffa3m3bg7fiv6ppwss51xqfd1"))))
+        (base32 "1r3wx0v3jm7j41h7gxr49izc9xa1afvrzq4wcdm0qbj98qa1rgpq"))))
     (build-system cmake-build-system)
     (inputs
      `(("alsa-lib" ,alsa-lib)
@@ -580,9 +580,6 @@ of other programs.")
        ("qttools" ,qttools)))
     (arguments
      '(#:tests? #f                      ; no tests
-       #:configure-flags
-       ;; TODO: prefetch translations files from 'lxqt-l10n'.
-       '("-DPULL_TRANSLATIONS=NO")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-source
@@ -591,6 +588,14 @@ of other programs.")
                             "menu/CMakeLists.txt")
                (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
                 "DESTINATION \"etc/xdg"))
+             #t))
+         (add-after 'unpack 'patch-translations-dir
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* '("cmake/BuildPlugin.cmake"
+                            "panel/CMakeLists.txt")
+               (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+                (string-append (assoc-ref outputs "out")
+                               "/share/lxqt/translations")))
              #t)))))
     (home-page "https://lxqt.org/")
     (synopsis "The LXQt desktop panel")