summary refs log tree commit diff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo@riseup.net>2019-03-13 23:37:25 +0800
committerDanny Milosavljevic <dannym@scratchpost.org>2019-03-14 16:47:18 +0100
commit45ef5374a70ec5458207623efd93400c66d2271c (patch)
tree7a741ac4d6bc26a14e1ecc7ee34222d514ccc659 /gnu/packages/lxqt.scm
parentc4a17525b9faf8993134c89966e3365c21e9fc50 (diff)
downloadguix-45ef5374a70ec5458207623efd93400c66d2271c.tar.gz
gnu: lxqt-policykit: Update to 0.14.1.
* gnu/packages/lxqt.scm (lxqt-policykit): Update to 0.14.1.
[arguments]: Remove #:configure-flags.
<#:phases>[patch-translations-dir]: New phase.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 3802a6f212..b606cfe556 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -605,14 +605,14 @@ of other programs.")
 (define-public lxqt-policykit
   (package
     (name "lxqt-policykit")
-    (version "0.13.0")
+    (version "0.14.1")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
                            version "/" name "-" version ".tar.xz"))
        (sha256
-        (base32 "1d97fys6625nk4q6irp0jhsbk30xi7idnii1f3vrrrdcl2cahagp"))))
+        (base32 "127rqb0nprybkc41lk0yq0r0dk5pbbw22gvrm4pwag71qh8wpk5i"))))
     (build-system cmake-build-system)
     (inputs
      `(("kwindowsystem" ,kwindowsystem)
@@ -630,8 +630,6 @@ of other programs.")
        ("qttools" ,qttools)))
     (arguments
      '(#:tests? #f                      ; no test target
-       #:configure-flags
-       '("-DPULL_TRANSLATIONS=NO")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-source
@@ -639,6 +637,13 @@ of other programs.")
              (substitute* '("autostart/CMakeLists.txt")
                (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
                 "DESTINATION \"etc/xdg"))
+             #t))
+         (add-after 'unpack 'patch-translations-dir
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* "CMakeLists.txt"
+               (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+                (string-append (assoc-ref outputs "out")
+                               "/share/lxqt/translations")))
              #t)))))
     (home-page "https://lxqt.org/")
     (synopsis "The LXQt PolicyKit agent")