summary refs log tree commit diff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo@riseup.net>2019-03-13 23:37:29 +0800
committerDanny Milosavljevic <dannym@scratchpost.org>2019-03-14 16:47:18 +0100
commit536afd9bf27a3b45096cb7c442d4e9bfcf23e8b3 (patch)
tree163d6e678b5c430ba12e78908c94922722d5b115 /gnu/packages/lxqt.scm
parent1b8daca27b60d5d311cc72d16519662046f679e7 (diff)
downloadguix-536afd9bf27a3b45096cb7c442d4e9bfcf23e8b3.tar.gz
gnu: lxqt-session: Update to 0.14.1.
* gnu/packages/lxqt.scm (lxqt-session): Update to 0.14.1.
[arguments]: Remove #:configure-flags.
<#:phases>[patch-translations-dir]: New phase.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 606bddaf7e..005096716b 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -790,14 +790,14 @@ allows for launching applications or shutting down the system.")
 (define-public lxqt-session
   (package
     (name "lxqt-session")
-    (version "0.13.0")
+    (version "0.14.1")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
                            version "/" name "-" version ".tar.xz"))
        (sha256
-        (base32 "1aibppppmg46ybbajx2qc395l0yp9rqlp2am01fqjxadsf8vci5z"))))
+        (base32 "11i2vimv3336dvvxb6y5csdybwjncr7cq3kwlj52vkpisnxslvgy"))))
     (build-system cmake-build-system)
     (inputs
      `(("eudev" ,eudev)
@@ -814,8 +814,6 @@ allows for launching applications or shutting down the system.")
        ("qttools" ,qttools)))
     (arguments
      `(#:tests? #f
-       #:configure-flags
-       `("-DPULL_TRANSLATIONS=NO")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-source
@@ -824,6 +822,15 @@ allows for launching applications or shutting down the system.")
                             "config/CMakeLists.txt")
                (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
                 "DESTINATION \"etc/xdg"))
+             #t))
+         (add-after 'unpack 'patch-translations-dir
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* '("lxqt-config-session/CMakeLists.txt"
+                            "lxqt-leave/CMakeLists.txt"
+                            "lxqt-session/CMakeLists.txt")
+               (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+                (string-append (assoc-ref outputs "out")
+                               "/share/lxqt/translations")))
              #t)))))
     (home-page "https://lxqt.org/")
     (synopsis "Session manager for LXQt")