summary refs log tree commit diff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2021-05-17 00:06:18 +1000
committerLudovic Courtès <ludo@gnu.org>2021-05-29 20:16:51 +0200
commit6d5ff521937cb1794a0b7c0437b2e7167a7e4aa2 (patch)
treeae4bbf7fa26c3e4b34efddf916e4d3c94495058d /gnu/packages/lxqt.scm
parent20eea7b9040f11cd36fd4e76f68b54d2bc051b0e (diff)
downloadguix-6d5ff521937cb1794a0b7c0437b2e7167a7e4aa2.tar.gz
gnu: lxqt-config: Move libkscreen to propagated-inputs.
* gnu/packages/lxqt.scm (lxqt-config): Move libkscreen to
propagated-inputs. Kscreen is a runtime dependency. lxqt-config-monitor
will not open without it available.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index fcccf669e4..c0a948db3c 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -376,7 +376,6 @@ the operating system LXQt is running on.")
     (inputs
      `(("eudev" ,eudev)
        ("kwindowsystem" ,kwindowsystem)
-       ("libkscreen" ,libkscreen)
        ("liblxqt" ,liblxqt)
        ("libqtxdg" ,libqtxdg)
        ("libxcursor" ,libxcursor)
@@ -392,6 +391,10 @@ the operating system LXQt is running on.")
      `(("pkg-config" ,pkg-config)
        ("lxqt-build-tools" ,lxqt-build-tools)
        ("qttools" ,qttools)))
+    ;; XXX: This is a workaround so libkscreen can find the backends as we
+    ;; dont have a way specify them. We may want to  patch like Nix does.
+    (propagated-inputs
+     `(("libkscreen" ,libkscreen)))
     (arguments
      '(#:tests? #f                      ; no tests
        #:phases