summary refs log tree commit diff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-10 17:52:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-10 19:27:08 +0200
commit7b9e90e40deceb74920adfdaaa758938f13fe594 (patch)
tree7d0e1bb729b6bf0bb45b6e4e910b9ff50705e97a /gnu/packages/machine-learning.scm
parent452fec7226bc697a71caa7ca1667ef6601d79245 (diff)
downloadguix-7b9e90e40deceb74920adfdaaa758938f13fe594.tar.gz
gnu: python-torchvision: Update to 0.15.2.
* gnu/packages/machine-learning.scm (python-torchvision): Update to 0.15.2.
[build-system]: Use pyproject-build-system.
[arguments]: Remove custom 'check phase.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm16
1 files changed, 5 insertions, 11 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 5489858d3a..6fc693a47b 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -3570,7 +3570,7 @@ implementations and an easy-to-use API to create custom metrics.  It offers:
 (define-public python-torchvision
   (package
     (name "python-torchvision")
-    (version "0.13.0")
+    (version "0.15.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -3580,17 +3580,11 @@ implementations and an easy-to-use API to create custom metrics.  It offers:
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "19f6s3ffwkdvjjbvib18c8n7vhysg58smxzq3rvii1c0z4g3b0cw"))))
-    (build-system python-build-system)
+                "1cq2s13vkgg9rljjbrm4g33yxq7q5zqp7f4xm5cq624gvs0wxmi8"))))
+    (build-system pyproject-build-system)
     (arguments
-     `(#:tests? #false ;the test suite is expensive and there is no easy way
-                       ;to subset it.
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "pytest" "-vv")))))))
+     (list #:tests? #false)) ;the test suite is expensive and there is no easy
+                             ;way to subset it.
     (inputs
      (list libpng
            libjpeg-turbo))