summary refs log tree commit diff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-18 20:09:37 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:55 -0400
commit34106c85d8a95c92d110bb657f09ada36401ff29 (patch)
tree5962e0159938ef0d28f0b6fb8aab44974baf77e2 /gnu/packages/machine-learning.scm
parent06b0512260b366513c7f3c3e8f9a6b298da968b7 (diff)
downloadguix-34106c85d8a95c92d110bb657f09ada36401ff29.tar.gz
gnu: python-umap-learn: Update to 0.5.3.
* gnu/packages/machine-learning.scm (python-umap-learn): Update to 0.5.3.
[source]: Use git.
[arguments]: New field.
[native-inputs]: Delete python-joblib and python-nose.  Add python-pytest.
[propagated-inputs]: Add python-pynndescent and python-tqdm.
[synopsis]: Fix indentation.
[description]: Fix typo and re-indent.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm40
1 files changed, 27 insertions, 13 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 5f14453f01..3897342345 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -2796,26 +2796,40 @@ These include a barrier, broadcast, and allreduce.")
 (define-public python-umap-learn
   (package
     (name "python-umap-learn")
-    (version "0.3.10")
+    (version "0.5.3")
     (source
      (origin
-       (method url-fetch)
-       (uri (pypi-uri "umap-learn" version))
+       (method git-fetch)               ;no tests in pypi release
+       (uri (git-reference
+             (url "https://github.com/lmcinnes/umap")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "02ada2yy6km6zgk2836kg1c97yrcpalvan34p8c57446finnpki1"))))
+         "1315jkb0h1b579y9m59632f0nnpksilm01nxx46in0rq8zna8vsb"))))
     (build-system python-build-system)
-    (native-inputs
-     (list python-joblib python-nose))
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (setenv "HOME" "/tmp")
+                (invoke "pytest" "-vv" "umap")))))))
+    (native-inputs (list python-pytest))
     (propagated-inputs
-     (list python-numba python-numpy python-scikit-learn python-scipy))
+     (list python-numba
+           python-numpy
+           python-pynndescent
+           python-scikit-learn
+           python-scipy
+           python-tqdm))
     (home-page "https://github.com/lmcinnes/umap")
-    (synopsis
-     "Uniform Manifold Approximation and Projection")
-    (description
-     "Uniform Manifold Approximation and Projection is a dimension reduction
-technique that can be used for visualisation similarly to t-SNE, but also for
-general non-linear dimension reduction.")
+    (synopsis "Uniform Manifold Approximation and Projection")
+    (description "Uniform Manifold Approximation and Projection is a dimension
+reduction technique that can be used for visualization similarly to t-SNE, but
+also for general non-linear dimension reduction.")
     (license license:bsd-3)))
 
 (define-public nnpack