summary refs log tree commit diff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-08 14:29:46 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-08 14:31:54 +0100
commitc8060055de425764f58bb9d0a7756964d7eea58d (patch)
tree4db6ef50868932f8ca779b49fdc6bb6e3f6c9aba /gnu/packages/machine-learning.scm
parentb835d10d61b0e21b8e85511e0a706cfef9ff3fc7 (diff)
downloadguix-c8060055de425764f58bb9d0a7756964d7eea58d.tar.gz
gnu: ocaml-mcl: Add -fcommon to compiler flags.
* gnu/packages/machine-learning.scm (ocaml-mcl)[arguments]: Add -fcommon.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 54be531da1..e75faefdf5 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -327,7 +327,7 @@ networks) based on simulation of (stochastic) flow in graphs.")
              (substitute* "setup.ml"
                (("LDFLAGS=-fPIC")
                 (string-append "LDFLAGS=-fPIC\"; \"SHELL=" (which "sh")))
-               (("-std=c89") "-std=gnu99")
+               (("-std=c89") "-std=gnu99 -fcommon")
 
                ;; This is a mutable string, which is no longer supported.  Use
                ;; a byte buffer instead.
@@ -340,7 +340,7 @@ networks) based on simulation of (stochastic) flow in graphs.")
                ((" s;")
                 " s);"))
              (substitute* "myocamlbuild.ml"
-               (("std=c89") "std=gnu99"))
+               (("std=c89") "std=gnu99 -fcommon"))
              ;; Since we build with a more recent OCaml, we have to use C99 or
              ;; later.  This causes problems with the old C code.
              (substitute* "src/impala/matrix.c"