summary refs log tree commit diff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2023-01-11 14:01:06 -0500
committer宋文武 <iyzsong@member.fsf.org>2023-01-28 14:00:36 +0800
commit79a37a8a71790fdc82f4c3184c93ac1a19deb164 (patch)
treeaf4cb0a03bb5e334e1eb783f27a15e1862c41fcd /gnu/packages/mail.scm
parent3411d36ddd027ef83b304558b1d331210df9dd46 (diff)
downloadguix-79a37a8a71790fdc82f4c3184c93ac1a19deb164.tar.gz
gnu: rss2email: Update to 3.14.
* gnu/packages/mail.scm (rss2email): Update to 3.14.
[arguments]: Use gexps.  Add install-documentation phase.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm33
1 files changed, 19 insertions, 14 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 2db1fb3743..80e2ce2a9b 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4684,7 +4684,7 @@ means--it's all programmable).")
 (define-public rss2email
   (package
     (name "rss2email")
-    (version "3.13.1")
+    (version "3.14")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -4693,21 +4693,26 @@ means--it's all programmable).")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0g1yr3v3ibdh2jqil64fbdbplx5m2yzxr893fqfkwcc5c7fbwl4d"))))
+                "0rmcwvf8whf49qq5rgp5hhmhfjli1vhjlc7fjhj24gyy1kkjir2k"))))
     (build-system python-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (with-directory-excursion "test"
-                 ;; Skip networking tests
-                 (substitute* "test.py"
-                   (("( *)class (:?TestSend|TestFetch).*" match indent)
-                    (string-append indent "@unittest.skip(\"Networking stuff skipped\")\n"
-                                   indent match)))
-                 (invoke "python" "-m" "unittest"))))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (with-directory-excursion "test"
+                  ;; Skip networking tests
+                  (substitute* "test.py"
+                    (("( *)class (:?TestSend|TestFetch).*" match indent)
+                     (string-append indent
+                                    "@unittest.skip(\"Networking stuff skipped\")\n"
+                                    indent match)))
+                  (invoke "python" "-m" "unittest")))))
+          (add-after 'install 'install-documentation
+            (lambda _
+              (install-file "r2e.1" (string-append #$output "share/man/man1")))))))
     (inputs
      (list python-feedparser python-html2text))
     (home-page "https://github.com/rss2email/rss2email")