summary refs log tree commit diff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:05 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:09 +0200
commitba20f088b99e2c4447b79664875045348e15b4c1 (patch)
tree2f458bcf7b237b704a07643386c7eb89e52fe126 /gnu/packages/mail.scm
parent1b8f9cea9b7286fe6f70d4f0a36e6d891f590825 (diff)
downloadguix-ba20f088b99e2c4447b79664875045348e15b4c1.tar.gz
gnu: gmime: Download sources from the git repository.
* gnu/packages/mail.scm (gmime)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
[arguments]: Add "--enable-gtk-doc=yes" to #:configure-flags.
Don't explicitly return #t from phases.
[native-inputs]: Add autoconf, automake, gtk-doc, libtool, and which.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm34
1 files changed, 21 insertions, 13 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 9d3525d486..16a30daff5 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -761,22 +761,31 @@ It adds a large amount of new and improved features to mutt.")
   (package
     (name "gmime")
     (version "3.2.7")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://gnome/sources/gmime/"
-                                  (version-major+minor version)
-                                  "/gmime-" version ".tar.xz"))
-              (sha256
-               (base32
-                "0i3xfc84qn1z99i70q68kbnp9rmgqrnprqb418ba52s6g9j9dsia"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jstedfast/gmime")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0yiylbw9iy49hgj29czinv246hh5c18qv6qkvbdrmq9z5m00sp01"))))
     (build-system gnu-build-system)
     (native-inputs
-     (list pkg-config gnupg ; for tests only
-           gobject-introspection vala))
+     (list autoconf
+           automake
+           pkg-config
+           gnupg                        ; for tests only
+           gobject-introspection
+           gtk-doc
+           libtool
+           vala
+           which))                      ; to find libtool, &c.
     (inputs (list glib gpgme zlib))
     (arguments
      `(#:configure-flags
-         (list "--enable-introspection=yes")
+         (list "--enable-gtk-doc=yes"
+               "--enable-introspection=yes")
        #:phases
        (modify-phases %standard-phases
          (add-after
@@ -792,8 +801,7 @@ It adds a large amount of new and improved features to mutt.")
                  (let* ((base (basename prog-path))
                         (prog (which base)))
                    (string-append pre
-                                  (or prog (error "not found: " base)))))))
-            #t)))))
+                                  (or prog (error "not found: " base))))))))))))
     (home-page "http://spruce.sourceforge.net/gmime/")
     (synopsis "MIME message parser and creator library")
     (description