summary refs log tree commit diff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:04 +0200
commit0c9f663cd20c1ccd29dfcbc02d8f2149fe3e3995 (patch)
tree8f6a81149c90e1ae9414c403e41de9c952a32b81 /gnu/packages/mail.scm
parent16d77b31c5024e9288dfd2f25f8eb6d0114a342c (diff)
downloadguix-0c9f663cd20c1ccd29dfcbc02d8f2149fe3e3995.tar.gz
gnu: nullmailer: Remove obsolete trailing #t.
* gnu/packages/mail.scm (nullmailer)[arguments]:
Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 6a1f33658e..7678c73be6 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -513,8 +513,7 @@ messages) using IDLE.  Implemented in Go.")
                (substitute* (list "functions.in"
                                   "tests/send")
                  ;; Fix some shebangs later generated on the fly.
-                 (("/bin/sh") (which "bash"))))
-             #t))
+                 (("/bin/sh") (which "bash"))))))
          (add-before 'check 'pass-PATH-to-tests
            ;; ‘runtest’ launches each test through ‘env -’, clearing $PATH. The
            ;; tests then source ‘functions’, which first demands a working $PATH
@@ -526,8 +525,7 @@ messages) using IDLE.  Implemented in Go.")
                  (("env - bash")
                   (string-append "env - PATH=\"" (getenv "PATH") "\" bash")))
                (substitute* "functions.in"
-                 (("export PATH=.*") "")))
-             #t))
+                 (("export PATH=.*") "")))))
          (add-before 'check 'delete-failing-tests
            (lambda _
              (with-directory-excursion "test/tests"
@@ -536,14 +534,12 @@ messages) using IDLE.  Implemented in Go.")
                           ;; XXX ‘nullmailer-inject: nullmailer-queue failed: 15’
                           "inject/queue"
                           ;; XXX These require the not-yet-packaged tcpserver.
-                          "protocols" "smtp-auth")))
-             #t))
+                          "protocols" "smtp-auth")))))
          (add-before 'install 'skip-install-data-local
            ;; Don't attempt to install run-time files outside of the store.
            (lambda _
              (substitute* "Makefile"
-               ((" install-data-local") ""))
-             #t)))))
+               ((" install-data-local") "")))))))
     (native-inputs
      ;; For tests.
      (list daemontools))   ; for svc