summary refs log tree commit diff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorng0 <contact.ng0@cryptolab.net>2017-02-15 10:09:27 +0000
committerKei Kebreau <kei@openmailbox.org>2017-04-08 12:40:28 -0400
commitd99a2add28bb6f5e79d23e7d6788d215372b370f (patch)
treee22b1f412454ba1608be3362f28f757c56c13cdd /gnu/packages/mail.scm
parent8a3741e61bc310090c73b521d29e67404336e590 (diff)
downloadguix-d99a2add28bb6f5e79d23e7d6788d215372b370f.tar.gz
gnu: Add postorius.
* gnu/packages/mail.scm (postorius): New variable.

Signed-off-by: Kei Kebreau <kei@openmailbox.org>
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 2585af99e6..b65c801162 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2101,6 +2101,36 @@ interacting with Mailman.")
        `(("python2-openid" ,python2-openid)
          ,@(package-propagated-inputs base))))))
 
+(define-public postorius
+  (package
+    (name "postorius")
+    (version "1.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "postorius" version "+post2.tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1wymcpv2icjjy8h1ni52p6dr7wwxf71ivqgbqhzx4i82yqphcaq5"))))
+    (build-system python-build-system)
+    (arguments
+     `(; One test dependency relies on Persona, which was shut down in
+       ;; November 2016.
+       #:tests? #f
+       ;; The part of the frontend of Mailman is still python 2.7.
+       #:python ,python-2))
+    (inputs
+     `(("python2-django" ,python2-django)
+       ("python2-django-mailman3" ,python2-django-mailman3)
+       ("python2-mailmanclient" ,python2-mailmanclient)))
+    (home-page "https://gitlab.com/mailman/postorius")
+    (synopsis "Web user interface for GNU Mailman")
+    (description
+     "Postorius is a Django app which provides a web user interface
+to access GNU Mailman.")
+    (license (list gpl3+ lgpl3+))))
+
 (define-public blists
   (package
     (name "blists")