summary refs log tree commit diff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2023-10-05 17:25:18 +0200
committerJohn Kehayias <john.kehayias@protonmail.com>2023-10-06 17:04:50 -0400
commitadd2a22ad7bcca2521432e3f486460138401d5a5 (patch)
treebcd5049a6e39e230f02b8ffe174acb0d85f9a44a /gnu/packages/mail.scm
parentad10bbe563c8019d1dada3dd98e6f12997608df6 (diff)
downloadguix-add2a22ad7bcca2521432e3f486460138401d5a5.tar.gz
gnu: exim: Update to 4.96.1 [security updates].
Fixes CVE-2023-42114, CVE-2023-42115, CVE-2023-42116, CVE-2023-42117,
CVE-2023-42118, and CVE-2023-42119.  See
<https://www.exim.org/static/doc/security/CVE-2023-zdi.txt> for more details.

* gnu/packages/mail.scm (exim): Update to 4.96.1.

Signed-off-by: John Kehayias <john.kehayias@protonmail.com>
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 73026012a9..fd324bf449 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -53,6 +53,7 @@
 ;;; Copyright © 2022 ( <paren@disroot.org>
 ;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
 ;;; Copyright © 2023 Arjan Adriaanse <arjan@adriaan.se>
+;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1885,7 +1886,7 @@ delivery.")
 (define-public exim
   (package
     (name "exim")
-    (version "4.96")
+    (version "4.96.1")
     (source
      (origin
        (method url-fetch)
@@ -1899,7 +1900,7 @@ delivery.")
                     (string-append "https://ftp.exim.org/pub/exim/exim4/old/"
                                    file-name))))
        (sha256
-        (base32 "18ziihkpa23lybm7m2l9wp2farxw0bd5ng7xm9ylgcrfgf95d6i9"))))
+        (base32 "0g83cxkq3znh5b3r2a3990qxysw7d2l71jwcxaxzvq8pqdahgb4k"))))
     (build-system gnu-build-system)
     (arguments
      (list #:phases