summary refs log tree commit diff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-10-08 16:39:19 +0100
committerChristopher Baines <mail@cbaines.net>2017-11-24 22:16:39 +0000
commitea3b9f7b737de2410be7c2facd3cf30a13e40f34 (patch)
treed84f96a4a39990afd908e97d6366073fdf3b5fc1 /gnu/packages/mail.scm
parent17dc2a0997f1ed416b56122eb56d86fd65795436 (diff)
downloadguix-ea3b9f7b737de2410be7c2facd3cf30a13e40f34.tar.gz
gnu: mail: Remove python-django-mailman3.
This package fails to build, as django-mailman3 currently only works with
Python 2.

* gnu/packages/mail.scm (python-django-mailman3): Removed variable.
  (python2-django-mailman3): Inline the use of python-django-mailman3, and
  remove the use of package-with-python2.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm41
1 files changed, 22 insertions, 19 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 38140d6e65..a8957e82ab 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2108,9 +2108,9 @@ installation on systems where resources are limited.  Its features include:
 @end enumerate\n")
     (license license:expat)))
 
-(define-public python-django-mailman3
+(define-public python2-django-mailman3
   (package
-    (name "python-django-mailman3")
+    (name "python2-django-mailman3")
     (version "1.0.1")
     (source
      (origin
@@ -2120,16 +2120,28 @@ installation on systems where resources are limited.  Its features include:
         (base32
          "1adxyh8knw9knjlh73xq0jpn5adml0ck4alsv0swakm95wfyx46z"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (zero?
+              (system*
+               "django-admin"
+               "test"
+               "--settings=django_mailman3.tests.settings_test"
+               "django_mailman3")))))
+       #:python ,python-2))
     (inputs
-     `(("python-django" ,python-django)))
+     `(("python2-django" ,python2-django)))
     (propagated-inputs
-     `(("python-requests" ,python-requests)
-       ("python-requests-oauthlib" ,python-requests-oauthlib)
-       ("python-openid" ,python-openid)
-       ("python-mailmanclient" ,python-mailmanclient)
-       ("python-django-allauth" ,python-django-allauth)
-       ("python-django-gravatar2" ,python-django-gravatar2)
-       ("python-pytz" ,python-pytz)))
+     `(("python2-requests" ,python2-requests)
+       ("python2-requests-oauthlib" ,python2-requests-oauthlib)
+       ("python2-openid" ,python2-openid)
+       ("python2-mailmanclient" ,python2-mailmanclient)
+       ("python2-django-allauth" ,python2-django-allauth)
+       ("python2-django-gravatar2" ,python2-django-gravatar2)
+       ("python2-pytz" ,python2-pytz)))
     (home-page "https://gitlab.com/mailman/django-mailman3")
     (synopsis "Django library for Mailman UIs")
     (description
@@ -2137,15 +2149,6 @@ installation on systems where resources are limited.  Its features include:
 interacting with Mailman.")
     (license gpl3+)))
 
-(define-public python2-django-mailman3
-  (let ((base (package-with-python2
-               python-django-mailman3)))
-    (package
-      (inherit base)
-      (propagated-inputs
-       `(("python2-openid" ,python2-openid)
-         ,@(package-propagated-inputs base))))))
-
 (define-public postorius
   (package
     (name "postorius")