summary refs log tree commit diff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorIvan Vilata-i-Balaguer <ivan@selidor.net>2020-01-13 20:44:05 -0500
committerLudovic Courtès <ludo@gnu.org>2020-02-05 00:21:27 +0100
commit892be267eee99f33920cd5f7307b7798edc1d8b0 (patch)
treeecf8211f1b4dc1f1c3dd0c09f8b1712695838707 /gnu/packages/mail.scm
parente3d80f3c1cd66c1290d28f44722a4cd3892cb20b (diff)
downloadguix-892be267eee99f33920cd5f7307b7798edc1d8b0.tar.gz
gnu: mutt: Enable Autocrypt support.
* gnu/packages/mail.scm (mutt)[inputs]: Add libidn2 and sqlite.
[arguments]<#:configure-flags>: Add "--enable-autocrypt", "--with-sqlite3" and
"--with-idn2".

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 0538342977..67aa079024 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -397,9 +397,11 @@ aliasing facilities to work just as they would on normal mail.")
      `(("cyrus-sasl" ,cyrus-sasl)
        ("gdbm" ,gdbm)
        ("gpgme" ,gpgme)
+       ("libidn2" ,libidn2)
        ("ncurses" ,ncurses)
        ("openssl" ,openssl)
-       ("perl" ,perl)))
+       ("perl" ,perl)
+       ("sqlite" ,sqlite)))
     (arguments
      `(#:configure-flags '("--enable-smtp"
                            "--enable-imap"
@@ -407,8 +409,11 @@ aliasing facilities to work just as they would on normal mail.")
                            "--enable-gpgme"
                            "--enable-hcache" ; for header caching
                            "--enable-sidebar"
+                           "--enable-autocrypt"
                            "--with-ssl"
                            "--with-sasl"
+                           "--with-sqlite3" ; required for Autocrypt
+                           "--with-idn2" ; recommended for Autocrypt
                            ;; so that mutt does not check whether the path
                            ;; exists, which it does not in the chroot
                            "--with-mailpath=/var/mail")))