summary refs log tree commit diff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-03-07 01:09:55 -0500
committerMark H Weaver <mhw@netris.org>2015-03-07 01:09:55 -0500
commit93c117eec3680c3f2b8d8fe4aafb99db352c468e (patch)
treec54f04d860e917dab8bd64ad5c1a3cec21a6263b /gnu/packages/mail.scm
parentdde70926568019c1000a1cf7863a3e44433774d7 (diff)
downloadguix-93c117eec3680c3f2b8d8fe4aafb99db352c468e.tar.gz
gnu: gmime: Use ISO-8859-1 when patching tests.
* gnu/packages/mail.scm (gmime)[arguments]: Use ISO-8859-1 when patching
  tests.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 33076c1a60..4aa74fe3ee 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -227,14 +227,16 @@ operating systems.")
        (alist-cons-after
         'unpack 'patch-paths-in-tests
         (lambda _
-          ;; The test programs run several programs using 'system'
-          ;; with hard-coded paths.  Here we patch them all.  We also
-          ;; change "gpg" to "gpg2".
-          (substitute* (find-files "tests" "\\.c$")
-            (("(system *\\(\")(/[^ ]*)" all pre prog-path)
-             (let* ((base (basename prog-path))
-                    (prog (which (if (string=? base "gpg") "gpg2" base))))
-              (string-append pre (or prog (error "not found: " base)))))))
+          ;; The test programs run several programs using 'system' with
+          ;; hard-coded paths.  Here we patch them all.  We also change "gpg"
+          ;; to "gpg2".  We use ISO-8859-1 here because test-iconv.c contains
+          ;; raw byte sequences in several different encodings.
+          (with-fluids ((%default-port-encoding #f))
+            (substitute* (find-files "tests" "\\.c$")
+              (("(system *\\(\")(/[^ ]*)" all pre prog-path)
+               (let* ((base (basename prog-path))
+                      (prog (which (if (string=? base "gpg") "gpg2" base))))
+                 (string-append pre (or prog (error "not found: " base))))))))
         %standard-phases)))
     (home-page "http://spruce.sourceforge.net/gmime/")
     (synopsis "MIME message parser and creator library")