summary refs log tree commit diff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-09-11 23:29:50 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-09-11 23:30:44 +0200
commit54151d1af52aa0b973ab91c5e017ebd14342b568 (patch)
tree3412e6b8bf3d9f1bfe73d05e76ce271e23453ae1 /gnu/packages/mail.scm
parentd9d88c2ff0d367599d0a851ccf9377c4e21079d6 (diff)
downloadguix-54151d1af52aa0b973ab91c5e017ebd14342b568.tar.gz
Revert "gnu: dovecot: Set moduledir to global directory."
This reverts commit db0109be42547d5dbb0fc1eb8ae30ccc968ed88b.
Same reason as commit d9d88c2ff0d367599d0a851ccf9377c4e21079d6.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 6721b5e4ee..4a9c6fc90f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1453,7 +1453,6 @@ facilities for checking incoming mail.")
     (arguments
      `(#:configure-flags '("--sysconfdir=/etc"
                            "--localstatedir=/var"
-                           "--with-moduledir=/etc/dovecot/modules"
                            "--with-sqlite"  ; not auto-detected
                            "--with-lucene") ; not auto-detected
        #:phases
@@ -1472,13 +1471,9 @@ facilities for checking incoming mail.")
                (("cat") (which "cat")))
              #t))
          (replace 'install
-           (lambda* (#:key outputs make-flags #:allow-other-keys)
-             ;; The .la files don't like having the moduledir moved.
-             (for-each delete-file (find-files "." "\\.la"))
+           (lambda* (#:key make-flags #:allow-other-keys)
              ;; Simple hack to avoid installing a trivial README in /etc.
              (apply invoke "make" "install" "sysconfdir=/tmp/bogus"
-                    (string-append "moduledir=" (assoc-ref outputs "out")
-                                   "/lib/dovecot")
                     make-flags))))))
     (home-page "https://www.dovecot.org")
     (synopsis "Secure POP3/IMAP server")