summary refs log tree commit diff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-05 05:05:28 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-06 05:24:17 +0100
commit0d78ac083a9095ae82e3c27f19e67691bcad41d1 (patch)
tree307734651ff067757e342203f4c34b4e06f4ec71 /gnu/packages/mail.scm
parentf9fe99b4cd65bba023fca109c9f2f63828f00e48 (diff)
downloadguix-0d78ac083a9095ae82e3c27f19e67691bcad41d1.tar.gz
gnu: pan: Update to 0.149.
* gnu/packages/mail.scm (pan): Update to 0.149.
[arguments]: Don't explicitly return #t from phases.
[inputs]: Upgrade gmime-2.6 to gmime.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index d5894e4d6e..8383a677f7 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -3780,14 +3780,14 @@ killed threads.")
 (define-public pan
   (package
     (name "pan")
-    (version "0.147")
+    (version "0.149")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "http://pan.rebelbase.com/download/releases/"
                            version "/source/" name "-" version ".tar.bz2"))
        (sha256
-        (base32 "0960siaf0r6m18kv0d8aqpf36x2xbsfcvk07kswlany7jbxrhylr"))))
+        (base32 "1sl5rdgalswxya61vhkf28r0fb4b3pq77qgzhhsfagmpvgbx0d2x"))))
     (arguments
      `(#:configure-flags '("--with-gtk3" "--with-gtkspell" "--with-gnutls"
                            "--enable-libnotify" "--enable-manual"
@@ -3799,10 +3799,9 @@ killed threads.")
              (substitute* "pan/usenet-utils/gpg.cc"
                (("\"gpg2\"") (string-append "\""
                                             (assoc-ref inputs "gnupg")
-                                            "/bin/gpg\"")))
-             #t)))))
+                                            "/bin/gpg\""))))))))
     (inputs
-     (list gmime-2.6
+     (list gmime
            gnupg
            gnutls
            gtk+