summary refs log tree commit diff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorykonai <mail@ykonai.net>2022-05-23 01:43:01 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-30 16:34:40 +0200
commit5e5e37fbc47236651d59448da60860c88e9241ed (patch)
tree6e6d6201acc81777e1ecd6fa6b8fd549a3d533ca /gnu/packages/mail.scm
parentb67fd51902014bf5ab21fd9a93f2ac710cb173bd (diff)
downloadguix-5e5e37fbc47236651d59448da60860c88e9241ed.tar.gz
gnu: rspamd: Update to 3.2
* gnu/packages/mail.scm (rspamd): Update to 3.2

I also added a new build option, that changes the LOCAL_CONFDIR variable to
/etc/rspamd. This allows for rspamd configuration via the /etc/rspamd/local.d
and override.d directories, which by default were located in the PREFIX which
is in /gnu/store.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index b44ba90582..c0b43f7c7f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4365,7 +4365,7 @@ on RFC 3501 and original @code{imaplib} module.")
 (define-public rspamd
   (package
     (name "rspamd")
-    (version "2.7")
+    (version "3.2")
     (source
      (origin
        (method git-fetch)
@@ -4373,11 +4373,12 @@ on RFC 3501 and original @code{imaplib} module.")
              (url "https://github.com/rspamd/rspamd")
              (commit version)))
        (sha256
-        (base32 "0fw6nbfc3xqapzq5nydakwgpw6cz6vb3qby2aqlr06lzf87d3hic"))
+        (base32 "122d5m1nfxxz93bhsk8lm4dazvdknzphb0a1188m7bsa4iynbfv2"))
        (file-name (git-file-name name version))))
     (build-system cmake-build-system)
     (arguments
-     '(#:configure-flags '("-DENABLE_LUAJIT=ON")))
+     '(#:configure-flags '("-DENABLE_LUAJIT=ON"
+                           "-DLOCAL_CONFDIR=/etc/rspamd")))
     (inputs
      (list openssl
            glib
@@ -4386,7 +4387,7 @@ on RFC 3501 and original @code{imaplib} module.")
            sqlite
            file
            icu4c
-           pcre
+           pcre2
            zlib
            perl
            libsodium))